aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
commit7a6a6464971c69fa1026aeaf8fad5c79250230e9 (patch)
treea68bcf07bd0d15b68d1b990877a55002585690b9 /target/linux/atheros-2.6/image/Makefile
parent927fb16abb41cfeeee4e97b4baed2d5ce036ca2e (diff)
downloadupstream-7a6a6464971c69fa1026aeaf8fad5c79250230e9.tar.gz
upstream-7a6a6464971c69fa1026aeaf8fad5c79250230e9.tar.bz2
upstream-7a6a6464971c69fa1026aeaf8fad5c79250230e9.zip
Add initial version of the new Image Builder It's still a bit rough in a few places, but it seems to work for Broadcom at least - other targets untested.
SVN-Revision: 6071
Diffstat (limited to 'target/linux/atheros-2.6/image/Makefile')
-rw-r--r--target/linux/atheros-2.6/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/atheros-2.6/image/Makefile b/target/linux/atheros-2.6/image/Makefile
index fb8cf3ced2..80e3335920 100644
--- a/target/linux/atheros-2.6/image/Makefile
+++ b/target/linux/atheros-2.6/image/Makefile
@@ -7,8 +7,12 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+define Image/Prepare
+ cp $(KDIR)/linux-*/vmlinux $(KDIR)/vmlinux.elf
+endef
+
define Image/BuildKernel
- cp $(KDIR)/linux-*/vmlinux $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
$(STAGING_DIR)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.lzma bs=65536 conv=sync