aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-02 01:38:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-02 01:38:07 +0000
commitd2c8e9104d4358641a5548b17a2c6b759ef4298b (patch)
tree27efd2fdefcd2bb14805781f454c8f4faf4246e1 /target/linux/atheros-2.6/image/Makefile
parent68ca8e7818356c0dbf2e0400b177139a656791c0 (diff)
downloadupstream-d2c8e9104d4358641a5548b17a2c6b759ef4298b.tar.gz
upstream-d2c8e9104d4358641a5548b17a2c6b759ef4298b.tar.bz2
upstream-d2c8e9104d4358641a5548b17a2c6b759ef4298b.zip
add squashfs support for atheros-2.6
SVN-Revision: 6451
Diffstat (limited to 'target/linux/atheros-2.6/image/Makefile')
-rw-r--r--target/linux/atheros-2.6/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/atheros-2.6/image/Makefile b/target/linux/atheros-2.6/image/Makefile
index 80e3335920..dfd1746fd3 100644
--- a/target/linux/atheros-2.6/image/Makefile
+++ b/target/linux/atheros-2.6/image/Makefile
@@ -19,7 +19,12 @@ define Image/BuildKernel
dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.gz bs=65536 conv=sync
endef
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
define Image/Build
+ $(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-root.$(1) bs=128k conv=sync
endef