aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-2.6.28/110-spiflash.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2009-02-20 16:27:42 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2009-02-20 16:27:42 +0000
commit668860c98f79e2b17febcaa1eb5c70aecdedbb9a (patch)
tree91616eac9f23649611a0ac944a33bbc63e9aa7dc /target/linux/atheros/patches-2.6.28/110-spiflash.patch
parentcde75fb5af88044e36cae6b24703eb51faca746b (diff)
downloadupstream-668860c98f79e2b17febcaa1eb5c70aecdedbb9a.tar.gz
upstream-668860c98f79e2b17febcaa1eb5c70aecdedbb9a.tar.bz2
upstream-668860c98f79e2b17febcaa1eb5c70aecdedbb9a.zip
Add initial kernel 2.6.28 support for atheros target. The include files moved from /include/asm-mips/mach-atheros/ to /arch/mips/include/asm/mach-atheros/ This patch is based on the old kernel 2.6.27 patches.
SVN-Revision: 14584
Diffstat (limited to 'target/linux/atheros/patches-2.6.28/110-spiflash.patch')
-rw-r--r--target/linux/atheros/patches-2.6.28/110-spiflash.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/atheros/patches-2.6.28/110-spiflash.patch b/target/linux/atheros/patches-2.6.28/110-spiflash.patch
new file mode 100644
index 0000000000..4b9b9d6891
--- /dev/null
+++ b/target/linux/atheros/patches-2.6.28/110-spiflash.patch
@@ -0,0 +1,20 @@
+--- a/drivers/mtd/devices/Kconfig
++++ b/drivers/mtd/devices/Kconfig
+@@ -104,6 +104,10 @@ config M25PXX_USE_FAST_READ
+ help
+ This option enables FAST_READ access supported by ST M25Pxx.
+
++config MTD_SPIFLASH
++ tristate "Atheros AR2315/6/7 SPI Flash support"
++ depends on ATHEROS_AR5315
++
+ config MTD_SLRAM
+ tristate "Uncached system RAM"
+ help
+--- a/drivers/mtd/devices/Makefile
++++ b/drivers/mtd/devices/Makefile
+@@ -16,3 +16,4 @@ obj-$(CONFIG_MTD_LART) += lart.o
+ obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd.o
+ obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
+ obj-$(CONFIG_MTD_M25P80) += m25p80.o
++obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o