aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-3.18/101-early-printk-support.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-13 02:57:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-13 02:57:59 +0000
commitfc7ff24b110212643738fddf0d7ef50db580991e (patch)
tree6033d0dd99d925a0edba3dc1b32d5fe5c44fea10 /target/linux/atheros/patches-3.18/101-early-printk-support.patch
parentcd34dcd2ced1900338c35f4ad02a23509dadac9c (diff)
downloadupstream-fc7ff24b110212643738fddf0d7ef50db580991e.tar.gz
upstream-fc7ff24b110212643738fddf0d7ef50db580991e.tar.bz2
upstream-fc7ff24b110212643738fddf0d7ef50db580991e.zip
atheros: v3.18: rename kernel platform to ath25
Rename platform source directory and asm includes directory. No functional changes. Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> SVN-Revision: 44707
Diffstat (limited to 'target/linux/atheros/patches-3.18/101-early-printk-support.patch')
-rw-r--r--target/linux/atheros/patches-3.18/101-early-printk-support.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/atheros/patches-3.18/101-early-printk-support.patch b/target/linux/atheros/patches-3.18/101-early-printk-support.patch
index 38560dd697..54446a4774 100644
--- a/target/linux/atheros/patches-3.18/101-early-printk-support.patch
+++ b/target/linux/atheros/patches-3.18/101-early-printk-support.patch
@@ -1,5 +1,5 @@
--- /dev/null
-+++ b/arch/mips/ar231x/early_printk.c
++++ b/arch/mips/ath25/early_printk.c
@@ -0,0 +1,46 @@
+/*
+ * This file is subject to the terms and conditions of the GNU General Public
@@ -14,8 +14,8 @@
+#include <linux/serial_reg.h>
+#include <asm/addrspace.h>
+
-+#include <asm/mach-ar231x/ar2315_regs.h>
-+#include <asm/mach-ar231x/ar5312_regs.h>
++#include <asm/mach-ath25/ar2315_regs.h>
++#include <asm/mach-ath25/ar5312_regs.h>
+#include "devices.h"
+
+static inline void prom_uart_wr(void __iomem *base, unsigned reg,
@@ -47,8 +47,8 @@
+ ;
+}
+
---- a/arch/mips/ar231x/Makefile
-+++ b/arch/mips/ar231x/Makefile
+--- a/arch/mips/ath25/Makefile
++++ b/arch/mips/ath25/Makefile
@@ -9,5 +9,8 @@
#