aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000-2.6
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
committerTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
commit03beb39e5f76f6361adc99244afb4d274310d158 (patch)
treead51f5b31163969f63c468720c0ac606bf0fe17e /target/linux/au1000-2.6
parentfa859ea32a7d0775e426b80757b37c09e3e2282c (diff)
downloadupstream-03beb39e5f76f6361adc99244afb4d274310d158.tar.gz
upstream-03beb39e5f76f6361adc99244afb4d274310d158.tar.bz2
upstream-03beb39e5f76f6361adc99244afb4d274310d158.zip
split out profile definitions from Makefiles
structure is as follows: target/linux/<arch>/profiles/<profilename>.mk These files are included by a blob match in the target Makefile The files should be labeled based on their profile Name in the definition SVN-Revision: 6468
Diffstat (limited to 'target/linux/au1000-2.6')
-rw-r--r--target/linux/au1000-2.6/Makefile19
-rw-r--r--target/linux/au1000-2.6/profiles/Atheros.mk13
-rw-r--r--target/linux/au1000-2.6/profiles/Broadcom.mk13
-rw-r--r--target/linux/au1000-2.6/profiles/Intel.mk13
4 files changed, 41 insertions, 17 deletions
diff --git a/target/linux/au1000-2.6/Makefile b/target/linux/au1000-2.6/Makefile
index 25fc776129..30259d55b7 100644
--- a/target/linux/au1000-2.6/Makefile
+++ b/target/linux/au1000-2.6/Makefile
@@ -25,23 +25,8 @@ define Kernel/BuildImage
$(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
endef
-define Profile/Atheros
- NAME:=Atheros WiFi (default)
- PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/Intel
- NAME:=Intel IPW2200 WiFi
- PACKAGES:=kmod-net-ipw2200
-endef
-$(eval $(call Profile,Intel))
-
-define Profile/Broadcom
- NAME:=Broadcom BCM43xx WiFi
- PACKAGES:=kmod-net-bcm43xx
-endef
-$(eval $(call Profile,Broadcom))
+# include the profiles
+-include profiles/*.mk
$(eval $(call BuildKernel))
diff --git a/target/linux/au1000-2.6/profiles/Atheros.mk b/target/linux/au1000-2.6/profiles/Atheros.mk
new file mode 100644
index 0000000000..ec6e175e80
--- /dev/null
+++ b/target/linux/au1000-2.6/profiles/Atheros.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/au1000-2.6/profiles/Broadcom.mk b/target/linux/au1000-2.6/profiles/Broadcom.mk
new file mode 100644
index 0000000000..d7fb9cb809
--- /dev/null
+++ b/target/linux/au1000-2.6/profiles/Broadcom.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom
+ NAME:=Broadcom BCM43xx WiFi
+ PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
diff --git a/target/linux/au1000-2.6/profiles/Intel.mk b/target/linux/au1000-2.6/profiles/Intel.mk
new file mode 100644
index 0000000000..be112eea91
--- /dev/null
+++ b/target/linux/au1000-2.6/profiles/Intel.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Intel
+ NAME:=Intel IPW2200 WiFi
+ PACKAGES:=kmod-net-ipw2200
+endef
+$(eval $(call Profile,Intel))
+