aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/avr32/image/u-boot
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-04-28 14:10:09 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-04-28 14:10:09 +0000
commit32e1595fb5006c7a41dbb38361dd3a4d658aa720 (patch)
treeabd8c68e1d4161585317532691b894b5cb125159 /target/linux/avr32/image/u-boot
parent5348fb9c74267e42ad948823965c6da0889ce8e3 (diff)
downloadupstream-32e1595fb5006c7a41dbb38361dd3a4d658aa720.tar.gz
upstream-32e1595fb5006c7a41dbb38361dd3a4d658aa720.tar.bz2
upstream-32e1595fb5006c7a41dbb38361dd3a4d658aa720.zip
enable optional building of u-boot for avr32
SVN-Revision: 10961
Diffstat (limited to 'target/linux/avr32/image/u-boot')
-rw-r--r--target/linux/avr32/image/u-boot/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/avr32/image/u-boot/Makefile b/target/linux/avr32/image/u-boot/Makefile
new file mode 100644
index 0000000000..c6db50c5b6
--- /dev/null
+++ b/target/linux/avr32/image/u-boot/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=u-boot
+PKG_VERSION:=1.3.2
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=78b1c2722d3907b5fae2cd219dbaf927
+PKG_CAT:=bzcat
+
+include $(INCLUDE_DIR)/package.mk
+
+UBOOT_CONFIG=$(strip $(subst ",, $(CONFIG_AVR32_UBOOT_TARGET)))
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
+ export CROSS_COMPILE=$(TARGET_CROSS);
+ $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/InstallDev
+ dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(BIN_DIR)/u-boot-$(CONFIG_AVR32_UBOOT_TARGET).bin bs=64k count=1 conv=sync
+endef
+
+$(eval $(call Build/DefaultTargets))