aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx
diff options
context:
space:
mode:
authorDaniel González Cabanelas <dgcbueu@gmail.com>2020-06-07 10:55:51 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2020-06-07 20:26:17 +0200
commit27c20a1ef5da22b91c1074a6dd044f0401ddfb2b (patch)
treeb2943116910cd3886fc2e14bdd05a04021b674c6 /target/linux/bcm63xx
parent598ba5b169acbd92c95ebbb2584b9ecb482e900f (diff)
downloadupstream-27c20a1ef5da22b91c1074a6dd044f0401ddfb2b.tar.gz
upstream-27c20a1ef5da22b91c1074a6dd044f0401ddfb2b.tar.bz2
upstream-27c20a1ef5da22b91c1074a6dd044f0401ddfb2b.zip
bcm63xx: image: don't add the CFE to the sercomm factory
There is no need to include the CFE bootloader in the Sercomm factory images. There might be a case when this could be useful: - We are running the stock firmware on the first Sercomm image - The second partition storing the botloader was erased (unlikely) Even in this case flashing an image without a bootlader is harmless. Don't include the bootloader in the factory image creation and rid of the risk of flashing factory images with an untested bootloader partition. Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
Diffstat (limited to 'target/linux/bcm63xx')
-rw-r--r--target/linux/bcm63xx/image/Makefile12
1 files changed, 0 insertions, 12 deletions
diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
index c962e531a9..294db6eb32 100644
--- a/target/linux/bcm63xx/image/Makefile
+++ b/target/linux/bcm63xx/image/Makefile
@@ -218,20 +218,8 @@ define Build/cfe-sercomm-part
--part-name rootfs_lib \
--part-version $(SERCOMM_VERSION)
- rm -rf $@-bootloader
- mkdir -p $@-bootloader
- cp $(KDIR)/bcm63xx-cfe/$(CFE_RAM_FILE) $@-bootloader/$(CFE_RAM_JFFS2_NAME)
- $(call Build/cfe-jffs2,$@-bootloader)
- $(call Build/pad-to,$(BLOCKSIZE))
- $(TOPDIR)/scripts/sercomm-partition-tag.py \
- --input-file $@ \
- --output-file $@.bootloader \
- --part-name bootloader \
- --part-version $(SERCOMM_VERSION)
-
mv $@.kernel_rootfs $@
dd if=$@.rootfs_lib >> $@
- dd if=$@.bootloader >> $@
endef
define Build/cfe-sercomm-load