aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/patches-5.10/600-mips-bmips-add-pci-support.patch
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2021-03-23 20:12:22 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2021-03-23 20:12:22 +0100
commit7f04d675170d255580edf77d4ff7c0adebb57609 (patch)
tree4cc1d76bc8d8497ef63c1a7b6ce68bd0d32eac9e /target/linux/bmips/patches-5.10/600-mips-bmips-add-pci-support.patch
parent851dadc257b7223f879a3733507e83cfcaae1af1 (diff)
downloadupstream-7f04d675170d255580edf77d4ff7c0adebb57609.tar.gz
upstream-7f04d675170d255580edf77d4ff7c0adebb57609.tar.bz2
upstream-7f04d675170d255580edf77d4ff7c0adebb57609.zip
bmips: add experimental PCI/PCIe support
These PCI drivers are a bit hacky and definitely not suitable for upstreaming, but hopefully we can use them as a base for developing proper upstream PCI drivers. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips/patches-5.10/600-mips-bmips-add-pci-support.patch')
-rw-r--r--target/linux/bmips/patches-5.10/600-mips-bmips-add-pci-support.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/bmips/patches-5.10/600-mips-bmips-add-pci-support.patch b/target/linux/bmips/patches-5.10/600-mips-bmips-add-pci-support.patch
new file mode 100644
index 0000000000..b4e7b7cfca
--- /dev/null
+++ b/target/linux/bmips/patches-5.10/600-mips-bmips-add-pci-support.patch
@@ -0,0 +1,20 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -262,6 +262,7 @@ config BMIPS_GENERIC
+ select BCM7038_L1_IRQ
+ select BCM7120_L2_IRQ
+ select BRCMSTB_L2_IRQ
++ select HAVE_PCI
+ select IRQ_MIPS_CPU
+ select DMA_NONCOHERENT
+ select SYS_SUPPORTS_32BIT_KERNEL
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -28,6 +28,7 @@ obj-$(CONFIG_PCI_XTALK_BRIDGE) += pci-xt
+ # These are still pretty much in the old state, watch, go blind.
+ #
+ obj-$(CONFIG_ATH79) += fixup-ath79.o
++obj-$(CONFIG_BMIPS_GENERIC) += fixup-bmips.o
+ obj-$(CONFIG_MIPS_COBALT) += fixup-cobalt.o
+ obj-$(CONFIG_LEMOTE_FULOONG2E) += fixup-fuloong2e.o ops-loongson2.o
+ obj-$(CONFIG_LEMOTE_MACH2F) += fixup-lemote2f.o ops-loongson2.o