aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/profiles
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2021-02-21 10:00:18 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2021-02-22 18:29:44 +0100
commit029093a302c9a66b74bec46285a179abd122a40a (patch)
tree505f9d21adf4f5d9acb51e7618f72cdbbc2d2ef9 /target/linux/bmips/profiles
parentc27532742d8cae7b9c1a8c2fbfe5157e65a20877 (diff)
downloadupstream-029093a302c9a66b74bec46285a179abd122a40a.tar.gz
upstream-029093a302c9a66b74bec46285a179abd122a40a.tar.bz2
upstream-029093a302c9a66b74bec46285a179abd122a40a.zip
bmips: add new target
This target has full device tree support, thus reducing the number of patches needed for bcm63xx, in which there's a patch for every board. The intention is to start with a minimal amount of downstream patches and start upstreaming all of them. Current status: - Enabling EHCI/OHCI on BCM6358 causes a kernel panic. - BCM63268 lacks Timer Clocks/Reset support. - No PCI/PCIe drivers. - No ethernet drivers. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Acked-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/bmips/profiles')
-rw-r--r--target/linux/bmips/profiles/default.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/bmips/profiles/default.mk b/target/linux/bmips/profiles/default.mk
new file mode 100644
index 0000000000..5b4edd6075
--- /dev/null
+++ b/target/linux/bmips/profiles/default.mk
@@ -0,0 +1,10 @@
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+
+$(eval $(call Profile,Default))