aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/patches-4.14/070-i2c_support.patch
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-02 00:29:21 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-12 13:43:52 +0200
commitde3e5de8ccfcdbc20c1c2b8798048189b9da6ed5 (patch)
treec3e90952575c7d74a09b24be8fb6c572bf493d7d /target/linux/cns3xxx/patches-4.14/070-i2c_support.patch
parente8931b309f82a44b55e64af3668186cdf7bcde15 (diff)
downloadupstream-de3e5de8ccfcdbc20c1c2b8798048189b9da6ed5.tar.gz
upstream-de3e5de8ccfcdbc20c1c2b8798048189b9da6ed5.tar.bz2
upstream-de3e5de8ccfcdbc20c1c2b8798048189b9da6ed5.zip
cns3xx: remove support for kernel 4.14
This target has been on kernel 4.19 for nine months now [1], and has had testing support for even longer [2]. This should be long enough to drop support for kernel 4.14. [1] 545bfbc3a922 ("cns3xxx: switch to kernel 4.19") [2] c6bebe1a9496 ("cns3xxx: add support for kernel 4.19") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/cns3xxx/patches-4.14/070-i2c_support.patch')
-rw-r--r--target/linux/cns3xxx/patches-4.14/070-i2c_support.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/target/linux/cns3xxx/patches-4.14/070-i2c_support.patch b/target/linux/cns3xxx/patches-4.14/070-i2c_support.patch
deleted file mode 100644
index 53a6f7ff5e..0000000000
--- a/target/linux/cns3xxx/patches-4.14/070-i2c_support.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/i2c/busses/Kconfig
-+++ b/drivers/i2c/busses/Kconfig
-@@ -474,6 +474,18 @@ config I2C_CBUS_GPIO
- This driver can also be built as a module. If so, the module
- will be called i2c-cbus-gpio.
-
-+config I2C_CNS3XXX
-+ tristate "Cavium CNS3xxx I2C driver"
-+ depends on ARCH_CNS3XXX
-+ help
-+ Support for Cavium CNS3xxx I2C controller driver.
-+
-+ This driver can also be built as a module. If so, the module
-+ will be called i2c-cns3xxx.
-+
-+ Please note that this driver might be needed to bring up other
-+ devices such as Cavium CNS3xxx Ethernet.
-+
- config I2C_CPM
- tristate "Freescale CPM1 or CPM2 (MPC8xx/826x)"
- depends on CPM1 || CPM2
---- a/drivers/i2c/busses/Makefile
-+++ b/drivers/i2c/busses/Makefile
-@@ -128,6 +128,7 @@ obj-$(CONFIG_I2C_VIPERBOARD) += i2c-vipe
- obj-$(CONFIG_I2C_ACORN) += i2c-acorn.o
- obj-$(CONFIG_I2C_BCM_KONA) += i2c-bcm-kona.o
- obj-$(CONFIG_I2C_BRCMSTB) += i2c-brcmstb.o
-+obj-$(CONFIG_I2C_CNS3XXX) += i2c-cns3xxx.o
- obj-$(CONFIG_I2C_CROS_EC_TUNNEL) += i2c-cros-ec-tunnel.o
- obj-$(CONFIG_I2C_ELEKTOR) += i2c-elektor.o
- obj-$(CONFIG_I2C_MLXCPLD) += i2c-mlxcpld.o