aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-04 21:00:14 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-04 21:00:14 +0000
commitb66332080257acb663ed7a4b5daa318fb6da13eb (patch)
tree2337dce529e6149824559965e2bf5cdf9c0e6036 /target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch
parent0f34590d5547059b8a8bd1bd3875f2f663fb1e6e (diff)
downloadupstream-b66332080257acb663ed7a4b5daa318fb6da13eb.tar.gz
upstream-b66332080257acb663ed7a4b5daa318fb6da13eb.tar.bz2
upstream-b66332080257acb663ed7a4b5daa318fb6da13eb.zip
[generic-2.4] add OCF 20100325 support to brcm-2.4
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21357 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch')
-rw-r--r--target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch b/target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch
new file mode 100644
index 0000000000..e176bf5366
--- /dev/null
+++ b/target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch
@@ -0,0 +1,21 @@
+--- a/crypto/Config.in
++++ b/crypto/Config.in
+@@ -117,4 +117,6 @@ if [ "$CONFIG_CRYPTO" = "y" ]; then
+ tristate ' Testing module' CONFIG_CRYPTO_TEST
+ fi
+
++source crypto/ocf/Config.in
++
+ endmenu
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -36,4 +36,9 @@ obj-$(CONFIG_CRYPTO_MICHAEL_MIC) += mich
+
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+
++mod-subdirs += ocf
++subdir-$(CONFIG_OCF_OCF) += ocf
++ocf-$(CONFIG_OCF_OCF) = ocf/ocfdrv.o
++obj-$(CONFIG_OCF_OCF) += $(ocf-y)
++
+ include $(TOPDIR)/Rules.make