aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-12-27 21:28:02 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-12-27 21:28:02 +0000
commit1fe38ff73bbb1397330adfcf331a1b9b871547df (patch)
treec611ef3a4ee2b8752582ad546268e481713166ba /target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch
parent858ea761172f225faac6ba07a59cb0b9497a6d88 (diff)
downloadupstream-1fe38ff73bbb1397330adfcf331a1b9b871547df.tar.gz
upstream-1fe38ff73bbb1397330adfcf331a1b9b871547df.tar.bz2
upstream-1fe38ff73bbb1397330adfcf331a1b9b871547df.zip
switch ixp4xx and ubicom32 to 2.6.30, get rid of 2.6.28 files
SVN-Revision: 18952
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch
deleted file mode 100644
index 198557aac1..0000000000
--- a/target/linux/generic-2.6/patches-2.6.28/410-gpio_buttons.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/drivers/input/misc/Kconfig
-+++ b/drivers/input/misc/Kconfig
-@@ -220,4 +220,20 @@ config HP_SDC_RTC
- Say Y here if you want to support the built-in real time clock
- of the HP SDC controller.
-
-+config INPUT_GPIO_BUTTONS
-+ tristate "Polled GPIO buttons interface"
-+ depends on GENERIC_GPIO
-+ select INPUT_POLLDEV
-+ help
-+ This driver implements support for buttons connected
-+ to GPIO pins of various CPUs (and some other chips).
-+
-+ Say Y here if your device has buttons connected
-+ directly to such GPIO pins. Your board-specific
-+ setup logic must also provide a platform device,
-+ with configuration data saying which GPIOs are used.
-+
-+ To compile this driver as a module, choose M here: the
-+ module will be called gpio-buttons.
-+
- endif
---- a/drivers/input/misc/Makefile
-+++ b/drivers/input/misc/Makefile
-@@ -21,3 +21,4 @@ obj-$(CONFIG_HP_SDC_RTC) += hp_sdc_rtc.
- obj-$(CONFIG_INPUT_UINPUT) += uinput.o
- obj-$(CONFIG_INPUT_APANEL) += apanel.o
- obj-$(CONFIG_INPUT_SGI_BTNS) += sgi_btns.o
-+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o