aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-05-28 10:00:48 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-05-28 10:00:48 +0000
commit7adb67f18469e51cecb83a0c2efbf22494acb244 (patch)
treefe225b163b00d82bf2dfa88ec105309675690049 /target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch
parent52d975c359b8330e2844d3bb942588bd5afd73e6 (diff)
downloadupstream-7adb67f18469e51cecb83a0c2efbf22494acb244.tar.gz
upstream-7adb67f18469e51cecb83a0c2efbf22494acb244.tar.bz2
upstream-7adb67f18469e51cecb83a0c2efbf22494acb244.zip
revert 15922 - add back 2.6.29 kernel support
SVN-Revision: 16127
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch
new file mode 100644
index 0000000000..20be29221a
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -560,6 +560,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+