aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.29/670-phy_ip175c.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-04-30 11:16:38 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-04-30 11:16:38 +0000
commitacb66fba6871d80da21a203e4b4e5d722a2b9fc7 (patch)
tree1389250a8771bc4e46b5919abbaac78e0cf64a0a /target/linux/generic-2.6/patches-2.6.29/670-phy_ip175c.patch
parentc146cbd79cf4d7d75dc16dab70a58b1a69264015 (diff)
downloadupstream-acb66fba6871d80da21a203e4b4e5d722a2b9fc7.tar.gz
upstream-acb66fba6871d80da21a203e4b4e5d722a2b9fc7.tar.bz2
upstream-acb66fba6871d80da21a203e4b4e5d722a2b9fc7.zip
generic-2.6: add ip175c stuff for 2.6.29
SVN-Revision: 15505
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.29/670-phy_ip175c.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.29/670-phy_ip175c.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.29/670-phy_ip175c.patch b/target/linux/generic-2.6/patches-2.6.29/670-phy_ip175c.patch
new file mode 100644
index 0000000000..461df50465
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.29/670-phy_ip175c.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -96,6 +96,10 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+
++config IP175C_PHY
++ tristate "Driver for IC+ IP175C/IP178C switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
++obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o