aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-04-28 13:35:14 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-04-28 13:35:14 +0000
commit2d0ccf7f5e0d98cb621550f88f19f7380fc06728 (patch)
tree9b1bdaac0af6496bf8da5f128461aeb79cd778c8 /target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch
parentf87df4b3615bc4e0bd9e19671f942f23782fb2ff (diff)
downloadupstream-2d0ccf7f5e0d98cb621550f88f19f7380fc06728.tar.gz
upstream-2d0ccf7f5e0d98cb621550f88f19f7380fc06728.tar.bz2
upstream-2d0ccf7f5e0d98cb621550f88f19f7380fc06728.zip
preliminary 2.6.30 support
SVN-Revision: 15468
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..b24d59cfff
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch
@@ -0,0 +1,25 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -778,6 +778,8 @@ config CRYPTO_ANSI_CPRNG
+ for cryptographic modules. Uses the Algorithm specified in
+ ANSI X9.31 A.2.4
+
++source "crypto/ocf/Kconfig"
++
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -85,6 +85,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+
+ #
++# OCF
++#
++obj-$(CONFIG_OCF_OCF) += ocf/
++
++#
+ # generic algorithms and the async_tx api
+ #
+ obj-$(CONFIG_XOR_BLOCKS) += xor.o