aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch
diff options
context:
space:
mode:
authorMatteo Croce <rootkit85@yahoo.it>2010-02-28 15:20:00 +0000
committerMatteo Croce <rootkit85@yahoo.it>2010-02-28 15:20:00 +0000
commit5ddd984cff128820f07b1f8e0ac7f8c845685855 (patch)
treebead993f23911a151c0afab7c1f7f7a12bac9737 /target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch
parent9fd2d20a246341b7b510de5a2de86d1f93a12887 (diff)
downloadupstream-5ddd984cff128820f07b1f8e0ac7f8c845685855.tar.gz
upstream-5ddd984cff128820f07b1f8e0ac7f8c845685855.tar.bz2
upstream-5ddd984cff128820f07b1f8e0ac7f8c845685855.zip
kernel: add 2.6.33 patches
SVN-Revision: 19905
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch b/target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch
new file mode 100644
index 0000000000..a4793cb63b
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -110,6 +110,10 @@ config AR8216_PHY
+ tristate "Driver for Atheros AR8216 switches"
+ select SWCONFIG
+
++config RTL8306_PHY
++ tristate "Driver for Realtek RTL8306S switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
++obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o