aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/backport-5.4/070-v5.5-MIPS-BPF-Restore-MIPS32-cBPF-JIT.patch
diff options
context:
space:
mode:
authorJohn Audia <graysky@archlinux.us>2020-08-11 12:13:19 -0400
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-18 18:14:54 +0200
commitda986035973a8c803e6f193ae502ff65e6d551c3 (patch)
tree76c59309057edc2b5f852c42bd8f8895150fb342 /target/linux/generic/backport-5.4/070-v5.5-MIPS-BPF-Restore-MIPS32-cBPF-JIT.patch
parent2cac31223d97fffacb8154f5739c67dfe078106f (diff)
downloadupstream-da986035973a8c803e6f193ae502ff65e6d551c3.tar.gz
upstream-da986035973a8c803e6f193ae502ff65e6d551c3.tar.bz2
upstream-da986035973a8c803e6f193ae502ff65e6d551c3.zip
kernel: bump 5.4 to 5.4.58
This PR is a blend of several kernel bumps authored by ldir taken from his staging tree w/ some further adjustments made by me and update_kernel.sh Summary: Deleted upstreamed patches: generic: 742-v5.5-net-sfp-add-support-for-module-quirks.patch 743-v5.5-net-sfp-add-some-quirks-for-GPON-modules.patch bcm63xx: 022-v5.8-mtd-rawnand-brcmnand-correctly-verify-erased-pages.patch 024-v5.8-mtd-rawnand-brcmnand-fix-CS0-layout.patch mediatek: 0402-net-ethernet-mtk_eth_soc-Always-call-mtk_gmac0_rgmii.patch Deleted patches applied differently upstream: generic: 641-sch_cake-fix-IP-protocol-handling-in-the-presence-of.patch Manually merged patches: generic: 395-v5.8-net-sch_cake-Take-advantage-of-skb-hash-where-appropriate.patch bcm27xx: 950-0132-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch layerscape: 701-net-0231-enetc-Use-DT-protocol-information-to-set-up-the-port.patch Build system: x86_64 Build-tested: ath79/generic, bcm27xx/bcm2708, bcm27xx/bcm2711, imx6, mvebu/cortexa9, sunxi/a53 Run-tested: Netgear R7800 (ipq806x) No dmesg regressions, everything functional Signed-off-by: John Audia <graysky@archlinux.us> Tested-By: Lucian Cristian <Lucian.cristian@gmail.com> [mvebu] Tested-By: Curtis Deptuck <curtdept@me.com> [x86/64] [do not remove 395-v5.8-net-sch_cake-Take-advantage-... patch, adjust and refresh patches, adjust commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-By: John Audia <graysky@archlinux.us> [ipq806x]
Diffstat (limited to 'target/linux/generic/backport-5.4/070-v5.5-MIPS-BPF-Restore-MIPS32-cBPF-JIT.patch')
-rw-r--r--target/linux/generic/backport-5.4/070-v5.5-MIPS-BPF-Restore-MIPS32-cBPF-JIT.patch13
1 files changed, 0 insertions, 13 deletions
diff --git a/target/linux/generic/backport-5.4/070-v5.5-MIPS-BPF-Restore-MIPS32-cBPF-JIT.patch b/target/linux/generic/backport-5.4/070-v5.5-MIPS-BPF-Restore-MIPS32-cBPF-JIT.patch
index 793c8be24a..027d0253a3 100644
--- a/target/linux/generic/backport-5.4/070-v5.5-MIPS-BPF-Restore-MIPS32-cBPF-JIT.patch
+++ b/target/linux/generic/backport-5.4/070-v5.5-MIPS-BPF-Restore-MIPS32-cBPF-JIT.patch
@@ -69,8 +69,6 @@ Cc: linux-kernel@vger.kernel.org
create mode 100644 arch/mips/net/bpf_jit.c
create mode 100644 arch/mips/net/bpf_jit_asm.S
-diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
-index e5c2d47608fe..33674cdc3aa8 100644
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -46,6 +46,7 @@ config MIPS
@@ -81,8 +79,6 @@ index e5c2d47608fe..33674cdc3aa8 100644
select HAVE_EBPF_JIT if 64BIT && !CPU_MICROMIPS && TARGET_ISA_REV >= 2
select HAVE_CONTEXT_TRACKING
select HAVE_COPY_THREAD_TLS
-diff --git a/arch/mips/net/Makefile b/arch/mips/net/Makefile
-index 2d03af7d6b19..d55912349039 100644
--- a/arch/mips/net/Makefile
+++ b/arch/mips/net/Makefile
@@ -1,4 +1,5 @@
@@ -91,9 +87,6 @@ index 2d03af7d6b19..d55912349039 100644
+obj-$(CONFIG_MIPS_CBPF_JIT) += bpf_jit.o bpf_jit_asm.o
obj-$(CONFIG_MIPS_EBPF_JIT) += ebpf_jit.o
-diff --git a/arch/mips/net/bpf_jit.c b/arch/mips/net/bpf_jit.c
-new file mode 100644
-index 000000000000..3a0e34f4e615
--- /dev/null
+++ b/arch/mips/net/bpf_jit.c
@@ -0,0 +1,1270 @@
@@ -1367,9 +1360,6 @@ index 000000000000..3a0e34f4e615
+
+ bpf_prog_unlock_free(fp);
+}
-diff --git a/arch/mips/net/bpf_jit_asm.S b/arch/mips/net/bpf_jit_asm.S
-new file mode 100644
-index 000000000000..57154c5883b6
--- /dev/null
+++ b/arch/mips/net/bpf_jit_asm.S
@@ -0,0 +1,285 @@
@@ -1658,6 +1648,3 @@ index 000000000000..57154c5883b6
+fault:
+ jr $r_ra
+ addiu $r_ret, zero, 1
---
-2.17.1
-