aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-01-05 00:20:05 +0000
committerJohn Crispin <john@openwrt.org>2013-01-05 00:20:05 +0000
commite6aac19237d1a480983fa486f9d8e3bee317d0f5 (patch)
tree1516d45ea4c47f63b6c77894ab95dc5443f6b24e /target/linux/generic/patches-3.3
parentba21190710c33527351342956fa3ebe42cb5c4c9 (diff)
downloadupstream-e6aac19237d1a480983fa486f9d8e3bee317d0f5.tar.gz
upstream-e6aac19237d1a480983fa486f9d8e3bee317d0f5.tar.bz2
upstream-e6aac19237d1a480983fa486f9d8e3bee317d0f5.zip
fix regmap debloat patch
SVN-Revision: 35015
Diffstat (limited to 'target/linux/generic/patches-3.3')
-rw-r--r--target/linux/generic/patches-3.3/270-regmap_dynamic.patch33
1 files changed, 27 insertions, 6 deletions
diff --git a/target/linux/generic/patches-3.3/270-regmap_dynamic.patch b/target/linux/generic/patches-3.3/270-regmap_dynamic.patch
index eaa6dbf367..a583cb4c40 100644
--- a/target/linux/generic/patches-3.3/270-regmap_dynamic.patch
+++ b/target/linux/generic/patches-3.3/270-regmap_dynamic.patch
@@ -1,6 +1,8 @@
---- a/drivers/base/regmap/Kconfig
-+++ b/drivers/base/regmap/Kconfig
-@@ -3,15 +3,16 @@
+Index: linux-3.3.8/drivers/base/regmap/Kconfig
+===================================================================
+--- linux-3.3.8.orig/drivers/base/regmap/Kconfig 2013-01-04 23:40:36.288481779 +0100
++++ linux-3.3.8/drivers/base/regmap/Kconfig 2013-01-04 23:40:39.760481927 +0100
+@@ -3,16 +3,17 @@
# subsystems should select the appropriate symbols.
config REGMAP
@@ -8,14 +10,33 @@
select LZO_COMPRESS
select LZO_DECOMPRESS
- bool
-+ tristate
++ tristate "Regmap"
config REGMAP_I2C
+- tristate
+ select REGMAP
- tristate
++ tristate "Regmap I2C"
config REGMAP_SPI
+- tristate
+ select REGMAP
- tristate
++ tristate "Regmap SPI"
config REGMAP_IRQ
+ bool
+Index: linux-3.3.8/drivers/base/regmap/Makefile
+===================================================================
+--- linux-3.3.8.orig/drivers/base/regmap/Makefile 2012-06-01 09:16:13.000000000 +0200
++++ linux-3.3.8/drivers/base/regmap/Makefile 2013-01-05 00:20:31.236584162 +0100
+@@ -1,6 +1,8 @@
+-obj-$(CONFIG_REGMAP) += regmap.o regcache.o
+-obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o
+-obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
++regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o
++ifdef CONFIG_DEBUGFS
++regmap-core-objs += regmap-debugfs.o
++endif
++obj-$(CONFIG_REGMAP) += regmap-core.o
+ obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
+ obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
+ obj-$(CONFIG_REGMAP_IRQ) += regmap-irq.o