aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.8/729-phy-rtl8367b.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-08 22:19:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-08 22:19:31 +0000
commit8dbed04ec9cad7771590af557b9edfe8e04bca8c (patch)
tree412beb5055a726a8f371c35580bdc85300e4e2f7 /target/linux/generic/patches-3.8/729-phy-rtl8367b.patch
parentc38cb63808ff1a395dd0384af23773b044adf9cb (diff)
downloadupstream-8dbed04ec9cad7771590af557b9edfe8e04bca8c.tar.gz
upstream-8dbed04ec9cad7771590af557b9edfe8e04bca8c.tar.bz2
upstream-8dbed04ec9cad7771590af557b9edfe8e04bca8c.zip
kernel: add support for 3.8-rc2
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 35055
Diffstat (limited to 'target/linux/generic/patches-3.8/729-phy-rtl8367b.patch')
-rw-r--r--target/linux/generic/patches-3.8/729-phy-rtl8367b.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.8/729-phy-rtl8367b.patch b/target/linux/generic/patches-3.8/729-phy-rtl8367b.patch
new file mode 100644
index 0000000000..4ab329fb79
--- /dev/null
+++ b/target/linux/generic/patches-3.8/729-phy-rtl8367b.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -246,6 +246,10 @@ config RTL8367_PHY
+ tristate "Driver for the Realtek RTL8367R/M switches"
+ select SWCONFIG
+
++config RTL8367B_PHY
++ tristate "Driver fot the Realtek RTL8367R-VB switch"
++ select SWCONFIG
++
+ endif # RTL8366_SMI
+
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -27,6 +27,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
++obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o