aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.0/830-ledtrig_morse.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-07 16:22:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-07 16:22:08 +0000
commitad133b57a94165e1289ac63b38139047a1450dbb (patch)
treeb59d5e2f60aface2db357eef2bd87d5d448c26a3 /target/linux/generic/patches-4.0/830-ledtrig_morse.patch
parent86a46a817ba7cfab4963818f9c97508f1f835762 (diff)
downloadupstream-ad133b57a94165e1289ac63b38139047a1450dbb.tar.gz
upstream-ad133b57a94165e1289ac63b38139047a1450dbb.tar.bz2
upstream-ad133b57a94165e1289ac63b38139047a1450dbb.zip
kernel: remove linux 4.0 support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47412
Diffstat (limited to 'target/linux/generic/patches-4.0/830-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-4.0/830-ledtrig_morse.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/target/linux/generic/patches-4.0/830-ledtrig_morse.patch b/target/linux/generic/patches-4.0/830-ledtrig_morse.patch
deleted file mode 100644
index 97cc33c1fc..0000000000
--- a/target/linux/generic/patches-4.0/830-ledtrig_morse.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/drivers/leds/trigger/Kconfig
-+++ b/drivers/leds/trigger/Kconfig
-@@ -108,4 +108,8 @@ config LEDS_TRIGGER_CAMERA
- This enables direct flash/torch on/off by the driver, kernel space.
- If unsure, say Y.
-
-+config LEDS_TRIGGER_MORSE
-+ tristate "LED Morse Trigger"
-+ depends on LEDS_TRIGGERS
-+
- endif # LEDS_TRIGGERS
---- a/drivers/leds/Makefile
-+++ b/drivers/leds/Makefile
-@@ -64,3 +64,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
-
- # LED Triggers
- obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
-+obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
---- a/drivers/leds/ledtrig-morse.c
-+++ b/drivers/leds/ledtrig-morse.c
-@@ -26,7 +26,6 @@
- #include <linux/list.h>
- #include <linux/spinlock.h>
- #include <linux/device.h>
--#include <linux/sysdev.h>
- #include <linux/timer.h>
- #include <linux/ctype.h>
- #include <linux/leds.h>