aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.1/201-extra_optimization.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-10 18:15:39 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-11 13:09:33 +0100
commitb7bee2858b582164d55c32be44df3fcb42cafc78 (patch)
treed908808a56549ec42e1b269421fd1be2dbd57f45 /target/linux/generic/patches-4.1/201-extra_optimization.patch
parentb1dbe6028eed57a89ae94c5e61e0b1e65f3aeb80 (diff)
downloadupstream-b7bee2858b582164d55c32be44df3fcb42cafc78.tar.gz
upstream-b7bee2858b582164d55c32be44df3fcb42cafc78.tar.bz2
upstream-b7bee2858b582164d55c32be44df3fcb42cafc78.zip
kernel: remove linux 4.1 support
The only target still referencing it is omap24xx, and it is marked as broken. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/generic/patches-4.1/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-4.1/201-extra_optimization.patch14
1 files changed, 0 insertions, 14 deletions
diff --git a/target/linux/generic/patches-4.1/201-extra_optimization.patch b/target/linux/generic/patches-4.1/201-extra_optimization.patch
deleted file mode 100644
index 34ded8c7eb..0000000000
--- a/target/linux/generic/patches-4.1/201-extra_optimization.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -612,9 +612,9 @@ include arch/$(SRCARCH)/Makefile
- KBUILD_CFLAGS += $(call cc-option,-fno-delete-null-pointer-checks,)
-
- ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
--KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
-+KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION) $(call cc-disable-warning,maybe-uninitialized,)
- else
--KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
- endif
-
- # Tell gcc to never replace conditional load with a non-conditional one