aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-10-11 19:08:08 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-10-11 19:08:08 +0000
commitb5842aed82e0c9101e99ec4bcf5959b931e98989 (patch)
treef9749eb8ce7d61f284cc4d91bac5aafd07de8344 /target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch
parent3d1a65adb41db2758827fe81f36d92ab61618ea3 (diff)
downloadupstream-b5842aed82e0c9101e99ec4bcf5959b931e98989.tar.gz
upstream-b5842aed82e0c9101e99ec4bcf5959b931e98989.tar.bz2
upstream-b5842aed82e0c9101e99ec4bcf5959b931e98989.zip
kernel: generic: add kernel 4.3
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47182
Diffstat (limited to 'target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..68f0a847d2
--- /dev/null
+++ b/target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1645,3 +1645,6 @@ source crypto/asymmetric_keys/Kconfig
+ source certs/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -119,6 +119,8 @@ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) +
+ obj-$(CONFIG_CRYPTO_USER_API_RNG) += algif_rng.o
+ obj-$(CONFIG_CRYPTO_USER_API_AEAD) += algif_aead.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #