aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/pending-3.18
diff options
context:
space:
mode:
authorMantas Pucka <mantas@8devices.com>2019-03-05 16:22:02 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-03-06 22:02:56 +0100
commita4ba41863b40fb11779a132e63d671d05649acda (patch)
tree00881330a5afba26d78f73e7122dfbc11b749c66 /target/linux/generic/pending-3.18
parente15bda603a9aad3564c46071c07b299703ec0f71 (diff)
downloadupstream-a4ba41863b40fb11779a132e63d671d05649acda.tar.gz
upstream-a4ba41863b40fb11779a132e63d671d05649acda.tar.bz2
upstream-a4ba41863b40fb11779a132e63d671d05649acda.zip
mips: fix dynamic ftrace
This was fixed for v4.9 in 076d2ea68, now port to all kernels Signed-off-by: Mantas Pucka <mantas@8devices.com>
Diffstat (limited to 'target/linux/generic/pending-3.18')
-rw-r--r--target/linux/generic/pending-3.18/305-mips_module_reloc.patch11
1 files changed, 8 insertions, 3 deletions
diff --git a/target/linux/generic/pending-3.18/305-mips_module_reloc.patch b/target/linux/generic/pending-3.18/305-mips_module_reloc.patch
index fae7e70f0e..6fe73178f6 100644
--- a/target/linux/generic/pending-3.18/305-mips_module_reloc.patch
+++ b/target/linux/generic/pending-3.18/305-mips_module_reloc.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -90,8 +90,13 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
+@@ -90,8 +90,18 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
cflags-y += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
cflags-y += -msoft-float
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib --gc-sections
@@ -8,8 +8,13 @@
KBUILD_AFLAGS_MODULE += -mlong-calls
KBUILD_CFLAGS_MODULE += -mlong-calls
+else
-+KBUILD_AFLAGS_MODULE += -mno-long-calls
-+KBUILD_CFLAGS_MODULE += -mno-long-calls
++ ifdef CONFIG_DYNAMIC_FTRACE
++ KBUILD_AFLAGS_MODULE += -mlong-calls
++ KBUILD_CFLAGS_MODULE += -mlong-calls
++ else
++ KBUILD_AFLAGS_MODULE += -mno-long-calls
++ KBUILD_CFLAGS_MODULE += -mno-long-calls
++ endif
+endif
ifndef CONFIG_FUNCTION_TRACER