aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2014-11-10 22:51:30 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2014-11-10 22:51:30 +0000
commita69ebe234d46ca95cbcbcba7f4ef9bae598eb95b (patch)
treef5a849fbbd0c2bb9bc9ba75b80f9ff679a707b09 /target/linux/generic
parentc5b5e68879238d195e7a797ca82c8e0043e797ee (diff)
downloadupstream-a69ebe234d46ca95cbcbcba7f4ef9bae598eb95b.tar.gz
upstream-a69ebe234d46ca95cbcbcba7f4ef9bae598eb95b.tar.bz2
upstream-a69ebe234d46ca95cbcbcba7f4ef9bae598eb95b.zip
kernel: update kernel 3.18 to rc4
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 43229
Diffstat (limited to 'target/linux/generic')
-rw-r--r--target/linux/generic/config-3.183
-rw-r--r--target/linux/generic/patches-3.18/204-module_strip.patch2
-rw-r--r--target/linux/generic/patches-3.18/220-gc_sections.patch4
-rw-r--r--target/linux/generic/patches-3.18/304-mips_disable_fpu.patch2
-rw-r--r--target/linux/generic/patches-3.18/472-mtd-m25p80-add-support-for-Winbond-W25X05-flash.patch2
-rw-r--r--target/linux/generic/patches-3.18/642-bridge_port_isolate.patch8
-rw-r--r--target/linux/generic/patches-3.18/643-bridge_remove_ipv6_dependency.patch4
-rw-r--r--target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch6
-rw-r--r--target/linux/generic/patches-3.18/653-disable_netlink_trim.patch2
-rw-r--r--target/linux/generic/patches-3.18/655-increase_skb_pad.patch2
-rw-r--r--target/linux/generic/patches-3.18/656-skb_reduce_truesize-helper.patch2
-rw-r--r--target/linux/generic/patches-3.18/721-phy_packets.patch4
-rw-r--r--target/linux/generic/patches-3.18/863-gpiommc.patch2
-rw-r--r--target/linux/generic/patches-3.18/903-debloat_direct_io.patch2
-rw-r--r--target/linux/generic/patches-3.18/950-vm_exports.patch4
15 files changed, 26 insertions, 23 deletions
diff --git a/target/linux/generic/config-3.18 b/target/linux/generic/config-3.18
index 21e58674aa..ad8ea95e9d 100644
--- a/target/linux/generic/config-3.18
+++ b/target/linux/generic/config-3.18
@@ -104,6 +104,7 @@ CONFIG_AIO=y
# CONFIG_AL3320A is not set
# CONFIG_ALCHEMY_GPIO_INDIRECT is not set
# CONFIG_ALIM7101_WDT is not set
+CONFIG_ALLOW_DEV_COREDUMP=y
# CONFIG_ALTERA_STAPL is not set
# CONFIG_ALTERA_TSE is not set
# CONFIG_ALX is not set
@@ -468,7 +469,9 @@ CONFIG_BOOKE_WDT_DEFAULT_TIMEOUT=3
# CONFIG_BOOT_PRINTK_DELAY is not set
CONFIG_BOOT_RAW=y
# CONFIG_BPCTL is not set
+CONFIG_BPF=y
# CONFIG_BPF_JIT is not set
+CONFIG_BPF_SYSCALL=y
# CONFIG_BPQETHER is not set
CONFIG_BQL=y
CONFIG_BRANCH_PROFILE_NONE=y
diff --git a/target/linux/generic/patches-3.18/204-module_strip.patch b/target/linux/generic/patches-3.18/204-module_strip.patch
index e63ef152d4..ed95eafd0d 100644
--- a/target/linux/generic/patches-3.18/204-module_strip.patch
+++ b/target/linux/generic/patches-3.18/204-module_strip.patch
@@ -93,7 +93,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
--- a/init/Kconfig
+++ b/init/Kconfig
-@@ -1973,6 +1973,13 @@ config MODULE_COMPRESS_XZ
+@@ -1987,6 +1987,13 @@ config MODULE_COMPRESS_XZ
endchoice
diff --git a/target/linux/generic/patches-3.18/220-gc_sections.patch b/target/linux/generic/patches-3.18/220-gc_sections.patch
index 86727f1661..105d1e7691 100644
--- a/target/linux/generic/patches-3.18/220-gc_sections.patch
+++ b/target/linux/generic/patches-3.18/220-gc_sections.patch
@@ -25,9 +25,9 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
+KBUILD_CFLAGS_KERNEL += -ffunction-sections -fdata-sections
+endif
+
- cflags-y += -ffreestanding
-
#
+ # pass -msoft-float to GAS if it supports it. However on newer binutils
+ # (specifically newer than 2.24.51.20140728) we then also need to explicitly
--- a/arch/mips/kernel/vmlinux.lds.S
+++ b/arch/mips/kernel/vmlinux.lds.S
@@ -67,7 +67,7 @@ SECTIONS
diff --git a/target/linux/generic/patches-3.18/304-mips_disable_fpu.patch b/target/linux/generic/patches-3.18/304-mips_disable_fpu.patch
index e3fadb9242..85cc65cd7c 100644
--- a/target/linux/generic/patches-3.18/304-mips_disable_fpu.patch
+++ b/target/linux/generic/patches-3.18/304-mips_disable_fpu.patch
@@ -49,7 +49,7 @@ v2: incorporated changes suggested by Jonas Gorski
select OF
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -266,7 +266,7 @@ OBJCOPYFLAGS += --remove-section=.regin
+@@ -275,7 +275,7 @@ OBJCOPYFLAGS += --remove-section=.regin
head-y := arch/mips/kernel/head.o
libs-y += arch/mips/lib/
diff --git a/target/linux/generic/patches-3.18/472-mtd-m25p80-add-support-for-Winbond-W25X05-flash.patch b/target/linux/generic/patches-3.18/472-mtd-m25p80-add-support-for-Winbond-W25X05-flash.patch
index a8c97c24e2..6bf516c71b 100644
--- a/target/linux/generic/patches-3.18/472-mtd-m25p80-add-support-for-Winbond-W25X05-flash.patch
+++ b/target/linux/generic/patches-3.18/472-mtd-m25p80-add-support-for-Winbond-W25X05-flash.patch
@@ -10,7 +10,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
--- a/drivers/mtd/spi-nor/spi-nor.c
+++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -614,6 +614,7 @@ const struct spi_device_id spi_nor_ids[]
+@@ -616,6 +616,7 @@ static const struct spi_device_id spi_no
{ "m25px80", INFO(0x207114, 0, 64 * 1024, 16, 0) },
/* Winbond -- w25x "blocks" are 64K, "sectors" are 4KiB */
diff --git a/target/linux/generic/patches-3.18/642-bridge_port_isolate.patch b/target/linux/generic/patches-3.18/642-bridge_port_isolate.patch
index a927827e79..c98b94796c 100644
--- a/target/linux/generic/patches-3.18/642-bridge_port_isolate.patch
+++ b/target/linux/generic/patches-3.18/642-bridge_port_isolate.patch
@@ -56,7 +56,7 @@
skb = NULL;
--- a/net/bridge/br_forward.c
+++ b/net/bridge/br_forward.c
-@@ -116,7 +116,7 @@ void br_deliver(const struct net_bridge_
+@@ -117,7 +117,7 @@ EXPORT_SYMBOL_GPL(br_deliver);
/* called with rcu_read_lock */
void br_forward(const struct net_bridge_port *to, struct sk_buff *skb, struct sk_buff *skb0)
{
@@ -65,7 +65,7 @@
if (skb0)
deliver_clone(to, skb, __br_forward);
else
-@@ -172,7 +172,7 @@ static void br_flood(struct net_bridge *
+@@ -173,7 +173,7 @@ static void br_flood(struct net_bridge *
struct sk_buff *skb0,
void (*__packet_hook)(const struct net_bridge_port *p,
struct sk_buff *skb),
@@ -74,7 +74,7 @@
{
struct net_bridge_port *p;
struct net_bridge_port *prev;
-@@ -180,6 +180,8 @@ static void br_flood(struct net_bridge *
+@@ -181,6 +181,8 @@ static void br_flood(struct net_bridge *
prev = NULL;
list_for_each_entry_rcu(p, &br->port_list, list) {
@@ -83,7 +83,7 @@
/* Do not flood unicast traffic to ports that turn it off */
if (unicast && !(p->flags & BR_FLOOD))
continue;
-@@ -206,14 +208,14 @@ out:
+@@ -207,14 +209,14 @@ out:
/* called with rcu_read_lock */
void br_flood_deliver(struct net_bridge *br, struct sk_buff *skb, bool unicast)
{
diff --git a/target/linux/generic/patches-3.18/643-bridge_remove_ipv6_dependency.patch b/target/linux/generic/patches-3.18/643-bridge_remove_ipv6_dependency.patch
index e5af533bc7..e8b21e5060 100644
--- a/target/linux/generic/patches-3.18/643-bridge_remove_ipv6_dependency.patch
+++ b/target/linux/generic/patches-3.18/643-bridge_remove_ipv6_dependency.patch
@@ -52,7 +52,7 @@
int __ipv6_get_lladdr(struct inet6_dev *idev, struct in6_addr *addr,
u32 banned_flags)
-@@ -5433,6 +5432,9 @@ int __init addrconf_init(void)
+@@ -5434,6 +5433,9 @@ int __init addrconf_init(void)
ipv6_addr_label_rtnl_register();
@@ -62,7 +62,7 @@
return 0;
errout:
rtnl_af_unregister(&inet6_ops);
-@@ -5452,6 +5454,9 @@ void addrconf_cleanup(void)
+@@ -5453,6 +5455,9 @@ void addrconf_cleanup(void)
struct net_device *dev;
int i;
diff --git a/target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch b/target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch
index 97a7f7f8de..35ed5cb403 100644
--- a/target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch
+++ b/target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch
@@ -291,7 +291,7 @@
rcu_assign_pointer(*pp, p);
--- a/net/bridge/br_forward.c
+++ b/net/bridge/br_forward.c
-@@ -167,6 +167,29 @@ out:
+@@ -168,6 +168,29 @@ out:
return p;
}
@@ -321,7 +321,7 @@
/* called under bridge lock */
static void br_flood(struct net_bridge *br, struct sk_buff *skb,
struct sk_buff *skb0,
-@@ -231,6 +254,7 @@ static void br_multicast_flood(struct ne
+@@ -232,6 +255,7 @@ static void br_multicast_flood(struct ne
struct net_bridge_port *prev = NULL;
struct net_bridge_port_group *p;
struct hlist_node *rp;
@@ -329,7 +329,7 @@
rp = rcu_dereference(hlist_first_rcu(&br->router_list));
p = mdst ? rcu_dereference(mdst->ports) : NULL;
-@@ -241,10 +265,19 @@ static void br_multicast_flood(struct ne
+@@ -242,10 +266,19 @@ static void br_multicast_flood(struct ne
rport = rp ? hlist_entry(rp, struct net_bridge_port, rlist) :
NULL;
diff --git a/target/linux/generic/patches-3.18/653-disable_netlink_trim.patch b/target/linux/generic/patches-3.18/653-disable_netlink_trim.patch
index 4bea5af59b..6b25a2e8f5 100644
--- a/target/linux/generic/patches-3.18/653-disable_netlink_trim.patch
+++ b/target/linux/generic/patches-3.18/653-disable_netlink_trim.patch
@@ -1,6 +1,6 @@
--- a/net/netlink/af_netlink.c
+++ b/net/netlink/af_netlink.c
-@@ -1705,27 +1705,7 @@ void netlink_detachskb(struct sock *sk,
+@@ -1715,27 +1715,7 @@ void netlink_detachskb(struct sock *sk,
static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
{
diff --git a/target/linux/generic/patches-3.18/655-increase_skb_pad.patch b/target/linux/generic/patches-3.18/655-increase_skb_pad.patch
index ea27cd28bd..96da16788a 100644
--- a/target/linux/generic/patches-3.18/655-increase_skb_pad.patch
+++ b/target/linux/generic/patches-3.18/655-increase_skb_pad.patch
@@ -1,6 +1,6 @@
--- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h
-@@ -2014,7 +2014,7 @@ static inline int pskb_network_may_pull(
+@@ -2022,7 +2022,7 @@ static inline int pskb_network_may_pull(
* NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
*/
#ifndef NET_SKB_PAD
diff --git a/target/linux/generic/patches-3.18/656-skb_reduce_truesize-helper.patch b/target/linux/generic/patches-3.18/656-skb_reduce_truesize-helper.patch
index 6471a853cc..48277930d4 100644
--- a/target/linux/generic/patches-3.18/656-skb_reduce_truesize-helper.patch
+++ b/target/linux/generic/patches-3.18/656-skb_reduce_truesize-helper.patch
@@ -14,7 +14,7 @@ when needed.
--- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h
-@@ -2059,6 +2059,24 @@ static inline void pskb_trim_unique(stru
+@@ -2067,6 +2067,24 @@ static inline void pskb_trim_unique(stru
BUG_ON(err);
}
diff --git a/target/linux/generic/patches-3.18/721-phy_packets.patch b/target/linux/generic/patches-3.18/721-phy_packets.patch
index 779ab4d0f2..0e21ff3080 100644
--- a/target/linux/generic/patches-3.18/721-phy_packets.patch
+++ b/target/linux/generic/patches-3.18/721-phy_packets.patch
@@ -41,7 +41,7 @@
*/
--- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h
-@@ -2044,6 +2044,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -2052,6 +2052,10 @@ static inline int pskb_trim(struct sk_bu
return (len < skb->len) ? __pskb_trim(skb, len) : 0;
}
@@ -52,7 +52,7 @@
/**
* pskb_trim_unique - remove end from a paged unique (not cloned) buffer
* @skb: buffer to alter
-@@ -2170,16 +2174,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -2178,16 +2182,6 @@ static inline struct sk_buff *dev_alloc_
}
diff --git a/target/linux/generic/patches-3.18/863-gpiommc.patch b/target/linux/generic/patches-3.18/863-gpiommc.patch
index 380f33782d..cdd1aea576 100644
--- a/target/linux/generic/patches-3.18/863-gpiommc.patch
+++ b/target/linux/generic/patches-3.18/863-gpiommc.patch
@@ -830,7 +830,7 @@
+be done automatically.
--- a/MAINTAINERS
+++ b/MAINTAINERS
-@@ -4263,6 +4263,11 @@ T: git git://linuxtv.org/anttip/media_tr
+@@ -4265,6 +4265,11 @@ T: git git://linuxtv.org/anttip/media_tr
S: Maintained
F: drivers/media/usb/hackrf/
diff --git a/target/linux/generic/patches-3.18/903-debloat_direct_io.patch b/target/linux/generic/patches-3.18/903-debloat_direct_io.patch
index 4bceec96cf..c633ed1e09 100644
--- a/target/linux/generic/patches-3.18/903-debloat_direct_io.patch
+++ b/target/linux/generic/patches-3.18/903-debloat_direct_io.patch
@@ -26,7 +26,7 @@
endif
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
-@@ -2526,12 +2526,25 @@ enum {
+@@ -2530,12 +2530,25 @@ enum {
DIO_ASYNC_EXTEND = 0x04,
};
diff --git a/target/linux/generic/patches-3.18/950-vm_exports.patch b/target/linux/generic/patches-3.18/950-vm_exports.patch
index d8dc186fb0..0291957bf0 100644
--- a/target/linux/generic/patches-3.18/950-vm_exports.patch
+++ b/target/linux/generic/patches-3.18/950-vm_exports.patch
@@ -52,7 +52,7 @@
* When we die, we re-parent all our children, and try to:
--- a/kernel/sched/core.c
+++ b/kernel/sched/core.c
-@@ -3147,6 +3147,7 @@ int can_nice(const struct task_struct *p
+@@ -3188,6 +3188,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
capable(CAP_SYS_NICE));
}
@@ -62,7 +62,7 @@
--- a/mm/memory.c
+++ b/mm/memory.c
-@@ -1403,6 +1403,7 @@ void zap_page_range(struct vm_area_struc
+@@ -1404,6 +1404,7 @@ void zap_page_range(struct vm_area_struc
mmu_notifier_invalidate_range_end(mm, start, end);
tlb_finish_mmu(&tlb, start, end);
}