aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/image
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2020-03-11 08:02:58 -0700
committerPetr Štetiar <ynezz@true.cz>2020-03-12 12:59:44 +0100
commit3666c67a5430abea1b70864e9cf218c1f192f5de (patch)
tree48f2752e0d0d928fad119cceb5eccd42f5462ce1 /target/linux/imx6/image
parent86b59d0709116209185f43b7c1144b198b38c1d2 (diff)
downloadupstream-3666c67a5430abea1b70864e9cf218c1f192f5de.tar.gz
upstream-3666c67a5430abea1b70864e9cf218c1f192f5de.tar.bz2
upstream-3666c67a5430abea1b70864e9cf218c1f192f5de.zip
imx6: add support for GW5907/GW5910/GW5912/GW5913
This patch adds support for GW5907/GW5910/GW5912/GW5913 IMX6 based boards from the Gateworks Ventana Family[A]: - backport upstream dt patches from 5.6 to 4.19 and 5.4 - add dtb's to ventana images - add board-name and network config A. https://www.gateworks.com/products/imx6-single-board-computer-gateworks-ventana-family Flashing instructions for Ventana boards: Using pre-flashed bootloader: - Use appropriate ubi image depending on board NAND to flash via bootloader: openwrt-imx6-ventana-squashfs-nand.ubi - 2KiB page size openwrt-imx6-ventana-large-squashfs-nand.ubi - 4KiB page size http://trac.gateworks.com/wiki/linux/ubi Using Gateworks JTAG dongle: - Use Gateworks mkimage_jtag script to create a JTAG image comprised of pre-built bootloader and ubi image: http://trac.gateworks.com/wiki/jtag_instructions Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Diffstat (limited to 'target/linux/imx6/image')
-rw-r--r--target/linux/imx6/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index d1e9e9034e..232dc4225f 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -143,6 +143,10 @@ define Device/ventana
imx6dl-gw552x \
imx6dl-gw553x \
imx6dl-gw5904 \
+ imx6dl-gw5907 \
+ imx6dl-gw5910 \
+ imx6dl-gw5912 \
+ imx6dl-gw5913 \
imx6q-gw51xx \
imx6q-gw52xx \
imx6q-gw53xx \
@@ -151,7 +155,11 @@ define Device/ventana
imx6q-gw551x \
imx6q-gw552x \
imx6q-gw553x \
- imx6q-gw5904
+ imx6q-gw5904 \
+ imx6q-gw5907 \
+ imx6q-gw5910 \
+ imx6q-gw5912 \
+ imx6q-gw5913
DEVICE_PACKAGES := kmod-sky2 kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
kmod-can kmod-can-flexcan kmod-can-raw \
kmod-hwmon-gsc \