aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/image
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2017-12-10 19:45:20 -0300
committerMathias Kresin <dev@kresin.me>2017-12-12 18:47:26 +0100
commit575178e4628cf32b97feec66c4a9726b4f30fa88 (patch)
treea0b4f3d5385222b9ce20ebbda645af3addf01980 /target/linux/imx6/image
parent72051f70368b53afa3305e1485c62b7e47fc1210 (diff)
downloadupstream-575178e4628cf32b97feec66c4a9726b4f30fa88.tar.gz
upstream-575178e4628cf32b97feec66c4a9726b4f30fa88.tar.bz2
upstream-575178e4628cf32b97feec66c4a9726b4f30fa88.zip
treewide: add only one device when appending to TARGET_DEVICES
This will avoid some conflicts when doing a git rebase or merge, specially when adding support to a new device. Signed-off-by: Luis Araneda <luaraneda@gmail.com> [drop brcm47xx changes which rename the images] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/imx6/image')
-rw-r--r--target/linux/imx6/image/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index c3653cd6fc..7f35c56b79 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -104,6 +104,7 @@ define Device/ventana
BLOCKSIZE := 128k
MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB
endef
+TARGET_DEVICES += ventana
define Device/ventana-large
$(Device/ventana)
@@ -114,14 +115,12 @@ define Device/ventana-large
BLOCKSIZE := 256k
MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB
endef
+TARGET_DEVICES += ventana-large
define Device/wandboard
DEVICE_TITLE := Wandboard Dual
DEVICE_DTS := imx6dl-wandboard
endef
-
-TARGET_DEVICES += \
- ventana ventana-large \
- wandboard
+TARGET_DEVICES += wandboard
$(eval $(call BuildImage))