aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-09-20 01:59:32 +0000
committerLuka Perkov <luka@openwrt.org>2013-09-20 01:59:32 +0000
commit3f059f58dba3a1fb9e1e5035b437273f095040f6 (patch)
tree44c82a0cd9241d3fc277920c5887520abc1ca419 /target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch
parent19bd25f4ecd20066554eb0c4df4cbff0213a9ae5 (diff)
downloadupstream-3f059f58dba3a1fb9e1e5035b437273f095040f6.tar.gz
upstream-3f059f58dba3a1fb9e1e5035b437273f095040f6.tar.bz2
upstream-3f059f58dba3a1fb9e1e5035b437273f095040f6.zip
imx6: update PCIe driver
Signed-off-by: Tim Harvey <tharvey@gateworks.com> Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38080
Diffstat (limited to 'target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch')
-rw-r--r--target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch b/target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch
new file mode 100644
index 0000000000..aef6b05f48
--- /dev/null
+++ b/target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch
@@ -0,0 +1,17 @@
+--- a/drivers/pci/Kconfig
++++ b/drivers/pci/Kconfig
+@@ -125,3 +125,5 @@ config PCI_IOAPIC
+ config PCI_LABEL
+ def_bool y if (DMI || ACPI)
+ select NLS
++
++source "drivers/pci/host/Kconfig"
+--- a/drivers/pci/Makefile
++++ b/drivers/pci/Makefile
+@@ -67,3 +67,6 @@ obj-$(CONFIG_XEN_PCIDEV_FRONTEND) += xen
+ obj-$(CONFIG_OF) += of.o
+
+ ccflags-$(CONFIG_PCI_DEBUG) := -DDEBUG
++
++# PCI host controller drivers
++obj-y += host/