aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/Makefile
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2021-05-25 15:26:06 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-06-06 00:26:13 +0200
commit1984a6bbcaac95c439dd4a6eba2f78c54e9be215 (patch)
tree1d774dee3d55ea73b06f48f5e618129c2c6738a1 /target/linux/ipq40xx/Makefile
parent609aa3978393d7436e5c9caba89d3356af021c80 (diff)
downloadupstream-1984a6bbcaac95c439dd4a6eba2f78c54e9be215.tar.gz
upstream-1984a6bbcaac95c439dd4a6eba2f78c54e9be215.tar.bz2
upstream-1984a6bbcaac95c439dd4a6eba2f78c54e9be215.zip
ipq40xx: add uboot-envtools to default packages
When support for Luma WRTQ-329ACN was added, the instructions for flashing this device include using tools from uboot-envtools package. Unfortunately the OpenWrt buildroot system omits packages from DEVICE_PACKAGES when CONFIG_TARGET_MULTI_PROFILE, CONFIG_TARGET_PER_DEVICE_ROOTFS, CONFIG_TARGET_ALL_PROFILES are set. In result the official images are without tools mentioned in the instruction. The workoround for the fashing would be installing uboot-envtools when booted with initramfs image, but not always the access to internet is available. The other method would be to issue the necesary command in U-Boot environment but some serial terminals default configuration don't work well with pasting lines longer than 80 chars. Therefore add uboot-envtools to default packages, which adds really small flash footprint to rootfs, where increased size usually is not an issue. Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/Makefile')
-rw-r--r--target/linux/ipq40xx/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/Makefile b/target/linux/ipq40xx/Makefile
index 43b1fcb0f9..400612376c 100644
--- a/target/linux/ipq40xx/Makefile
+++ b/target/linux/ipq40xx/Makefile
@@ -18,6 +18,7 @@ DEFAULT_PACKAGES += \
kmod-usb-dwc3-qcom \
kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
kmod-ath10k-ct wpad-basic-wolfssl \
- kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct
+ kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct \
+ uboot-envtools
$(eval $(call BuildTarget))