aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/Makefile
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-06-13 16:57:53 +0200
committerDavid Bauer <mail@david-bauer.net>2020-06-13 16:57:53 +0200
commitb8ed898f1bb809df1f5a16b34198c812236e9ff2 (patch)
tree5ab1cda39328e7c0f33ebe9c363676221e9b504f /target/linux/ipq40xx/image/Makefile
parent752cee796d0310989b9543150397985ea302688f (diff)
downloadupstream-b8ed898f1bb809df1f5a16b34198c812236e9ff2.tar.gz
upstream-b8ed898f1bb809df1f5a16b34198c812236e9ff2.tar.bz2
upstream-b8ed898f1bb809df1f5a16b34198c812236e9ff2.zip
ipq40xx: use zImage for EX6100v2 and EX6150v2
The NETGEAR EX61500v2 and EX6150v2 U-Boot does not support booting LZMA compressed images. Currently, they are using GZIP compressed kernels, which results in ledd flash being available to the root and overlay filesystems. Using a zImage results in a smaller kernel and therefore increases available space for rootfs and overlayfs. Size reduced: ~1.1 MiB Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ipq40xx/image/Makefile')
-rw-r--r--target/linux/ipq40xx/image/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 1d9f20b85f..7ca26ba517 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -43,9 +43,7 @@ define Device/UbiFit
endef
define Device/DniImage
- KERNEL_SUFFIX := -fit-uImage.itb
- KERNEL = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
- KERNEL_NAME := Image
+ $(call Device/FitzImage)
NETGEAR_BOARD_ID :=
NETGEAR_HW_ID :=
IMAGES := factory.img sysupgrade.bin