aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-09-18 22:31:59 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-10-07 18:07:54 +0200
commit8f29e36963e799c7aa5362bb5ad4c303890dc1c3 (patch)
treeafe634cfea44adfaecfd6d3c8b81ade048758750 /target/linux/ipq40xx/image
parentd181b2cefa5881d270e0e4cf9f42d1feaf2f7222 (diff)
downloadupstream-8f29e36963e799c7aa5362bb5ad4c303890dc1c3.tar.gz
upstream-8f29e36963e799c7aa5362bb5ad4c303890dc1c3.tar.bz2
upstream-8f29e36963e799c7aa5362bb5ad4c303890dc1c3.zip
ipq40xx: improve support for Edgecore ECW5211
This adds several stylistic and functional improvements of the recently added Edgecore ECW5211, especially: * Drop the local BDFs as those are already in the upstream under different names * Add SPDX tag to DTS * Add label MAC address * Move LED trigger to DTS * Remove unnecessary status="okay" * Disable unused SS USB phy as the USB port only supports USB 2.0 * Make uboot-env partition writable * Remove qcom,poll_required_dynamic property as the driver does not use it * Tidy up the device recipe Fixes: 4488b260a02e ("ipq40xx: add Edgecore ECW5211 support") Signed-off-by: Sungbo Eo <mans0n@gorani.run> Acked-by: Robert Marko <robert.marko@sartura.hr>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 6e5620a140..142896bde8 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -347,12 +347,12 @@ TARGET_DEVICES += dlink_dap-2610
define Device/edgecore_ecw5211
$(call Device/FitImage)
$(call Device/UbiFit)
- DEVICE_TITLE := Edgecore ECW5211
+ DEVICE_VENDOR := Edgecore
+ DEVICE_MODEL := ECW5211
+ SOC := qcom-ipq4018
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
- DEVICE_DTS := qcom-ipq4018-ecw5211
- DEVICE_PACKAGES := ipq-wifi-edgecore_ecw5211 kmod-tpm-i2c-atmel kmod-usb-acm uboot-envtools
+ DEVICE_PACKAGES := kmod-tpm-i2c-atmel kmod-usb-acm uboot-envtools
endef
TARGET_DEVICES += edgecore_ecw5211