aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/patches-5.4
diff options
context:
space:
mode:
authorRobert Marko <robert.marko@sartura.hr>2020-09-07 12:50:45 +0200
committerJohn Crispin <john@phrozen.org>2020-09-17 08:43:03 +0200
commit4488b260a02e169d6902df44debbe9b3c8e001cc (patch)
tree15d91d9eadc876a7f229b1201f4e492a9564d884 /target/linux/ipq40xx/patches-5.4
parent59f0a0fd839e239987ca14dcefe19717aaa71cd0 (diff)
downloadupstream-4488b260a02e169d6902df44debbe9b3c8e001cc.tar.gz
upstream-4488b260a02e169d6902df44debbe9b3c8e001cc.tar.bz2
upstream-4488b260a02e169d6902df44debbe9b3c8e001cc.zip
ipq40xx: add Edgecore ECW5211 support
This patch adds support for the Edgecore ECW5211 indoor AP. Specification: - SoC: Qualcomm Atheros IPQ4018 ARMv7-A 4x Cortex A-7 - RAM: 256MB DDR3 - NOR Flash: 16MB SPI NOR - NAND Flash: 128MB MX35LFxGE4AB SPI-NAND - Ethernet: 2 x 1G via Q8075 PHY connected to ethernet adapter via PSGMII (802.3af POE IN on eth0) - USB: 1 x USB 3.0 SuperSpeed - WLAN: Built-in IPQ4018 (2x2 802.11bng, 2x2 802.11 acn) - CC2540 BLE connected to USB 2.0 port - Atmel AT97SC3205T I2C TPM Signed-off-by: Robert Marko <robert.marko@sartura.hr>
Diffstat (limited to 'target/linux/ipq40xx/patches-5.4')
-rw-r--r--target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch9
1 files changed, 6 insertions, 3 deletions
diff --git a/target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch b/target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch
index d281bb468d..ea45606c27 100644
--- a/target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch
+++ b/target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch
@@ -8,9 +8,11 @@ Signed-off-by: John Crispin <john@phrozen.org>
arch/arm/boot/dts/Makefile | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -837,11 +837,50 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+Index: linux-5.4.63/arch/arm/boot/dts/Makefile
+===================================================================
+--- linux-5.4.63.orig/arch/arm/boot/dts/Makefile
++++ linux-5.4.63/arch/arm/boot/dts/Makefile
+@@ -837,11 +837,51 @@ dtb-$(CONFIG_ARCH_QCOM) += \
qcom-apq8074-dragonboard.dtb \
qcom-apq8084-ifc6540.dtb \
qcom-apq8084-mtp.dtb \
@@ -20,6 +22,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
+ qcom-ipq4018-cs-w3-wd1200g-eup.dtb \
+ qcom-ipq4018-ea6350v3.dtb \
+ qcom-ipq4018-eap1300.dtb \
++ qcom-ipq4018-ecw5211.dtb \
+ qcom-ipq4018-emd1.dtb \
+ qcom-ipq4018-emr3500.dtb \
+ qcom-ipq4018-ens620ext.dtb \