aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/files-5.4/arch/arm/boot
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-19 13:16:52 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-19 13:32:11 +0200
commit95c9df79712541627ad5f1cd38a1144decc14474 (patch)
tree1cb0efbd59c929454a4fa7d8691ba3c1310976dc /target/linux/ipq806x/files-5.4/arch/arm/boot
parent770a9c678756462ab0d94656f1fcc30624a31bd0 (diff)
downloadupstream-95c9df79712541627ad5f1cd38a1144decc14474.tar.gz
upstream-95c9df79712541627ad5f1cd38a1144decc14474.tar.bz2
upstream-95c9df79712541627ad5f1cd38a1144decc14474.zip
ipq806x: fix support of Edgecore ECW5410 support
This fixes several stylistic and functional errors of the recently added Edgecore ECW5410: - fix call in 11-ath10k-caldata - use hex notation in 11-ath10k-caldata - remove redundant definitions from DTS that are already in DTSI - use proper sorting in image/Makefile - use DEVICE_VENDOR/DEVICE_MODEL instead of DEVICE_TITLE - use SOC instead of DEVICE_DTS Fixes: 59f0a0fd839e ("ipq806x: add Edgecore ECW5410 support") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ipq806x/files-5.4/arch/arm/boot')
-rw-r--r--target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8068-ecw5410.dts73
1 files changed, 6 insertions, 67 deletions
diff --git a/target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8068-ecw5410.dts b/target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8068-ecw5410.dts
index 6d216bd85e..9d6afa1c8a 100644
--- a/target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8068-ecw5410.dts
+++ b/target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8068-ecw5410.dts
@@ -8,10 +8,6 @@
compatible = "edgecore,ecw5410", "qcom,ipq8064";
reserved-memory {
- #address-cells = <1>;
- #size-cells = <1>;
- ranges;
-
nss@40000000 {
reg = <0x40000000 0x1000000>;
no-map;
@@ -26,11 +22,6 @@
reg = <0x44000000 0x600000>;
no-map;
};
-
- rsvd@41200000 {
- reg = <0x41200000 0x300000>;
- no-map;
- };
};
cpus {
@@ -42,21 +33,19 @@
};
aliases {
- serial0 = &gsbi4_serial;
serial1 = &gsbi1_serial;
mdio-gpio0 = &mdio0;
ethernet0 = &gmac3;
ethernet1 = &gmac2;
- led-boot = &power_green;
- led-failsafe = &power_red;
- led-running = &power_green;
- led-upgrade = &power_green;
+ led-boot = &led_power_green;
+ led-failsafe = &led_power_red;
+ led-running = &led_power_green;
+ led-upgrade = &led_power_green;
};
chosen {
bootargs-append = " console=ttyMSM0,115200n8 root=/dev/ubiblock0_1";
- stdout-path = "serial0:115200n8";
};
keys {
@@ -76,7 +65,7 @@
pinctrl-0 = <&led_pins>;
pinctrl-names = "default";
- power_green: power_green {
+ led_power_green: power_green {
label = "ecw5410:green:power";
gpios = <&qcom_pinmux 16 GPIO_ACTIVE_HIGH>;
};
@@ -96,7 +85,7 @@
gpios = <&qcom_pinmux 26 GPIO_ACTIVE_LOW>;
};
- power_red: power_red {
+ led_power_red: power_red {
label = "ecw5410:red:power";
gpios = <&qcom_pinmux 28 GPIO_ACTIVE_LOW>;
};
@@ -133,40 +122,6 @@
};
};
- nand_pins: nand_pins {
- disable {
- pins = "gpio34", "gpio35", "gpio36", "gpio37",
- "gpio38";
- function = "nand";
- drive-strength = <10>;
- bias-disable;
- };
-
- pullups {
- pins = "gpio39";
- function = "nand";
- drive-strength = <10>;
- bias-pull-up;
- };
-
- hold {
- pins = "gpio40", "gpio41", "gpio42", "gpio43",
- "gpio44", "gpio45", "gpio46", "gpio47";
- function = "nand";
- drive-strength = <10>;
- bias-bus-hold;
- };
- };
-
- mdio0_pins: mdio0_pins {
- mux {
- pins = "gpio0", "gpio1";
- function = "gpio";
- drive-strength = <8>;
- bias-disable;
- };
- };
-
led_pins: led_pins {
mux {
pins = "gpio16", "gpio23", "gpio24", "gpio26",
@@ -208,22 +163,6 @@
};
};
-&gsbi4 {
- qcom,mode = <GSBI_PROT_I2C_UART>;
- status = "okay";
-
- serial@16340000 {
- status = "okay";
- };
-
- /*
- * The i2c device on gsbi4 should not be enabled.
- * On ipq806x designs gsbi4 i2c is meant for exclusive
- * RPM usage. Turning this on in kernel manifests as
- * i2c failure for the RPM.
- */
-};
-
&gsbi5 {
qcom,mode = <GSBI_PROT_SPI>;
status = "okay";