aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-19 13:16:52 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-19 13:32:11 +0200
commit95c9df79712541627ad5f1cd38a1144decc14474 (patch)
tree1cb0efbd59c929454a4fa7d8691ba3c1310976dc /target/linux/ipq806x/image/Makefile
parent770a9c678756462ab0d94656f1fcc30624a31bd0 (diff)
downloadupstream-95c9df79712541627ad5f1cd38a1144decc14474.tar.gz
upstream-95c9df79712541627ad5f1cd38a1144decc14474.tar.bz2
upstream-95c9df79712541627ad5f1cd38a1144decc14474.zip
ipq806x: fix support of Edgecore ECW5410 support
This fixes several stylistic and functional errors of the recently added Edgecore ECW5410: - fix call in 11-ath10k-caldata - use hex notation in 11-ath10k-caldata - remove redundant definitions from DTS that are already in DTSI - use proper sorting in image/Makefile - use DEVICE_VENDOR/DEVICE_MODEL instead of DEVICE_TITLE - use SOC instead of DEVICE_DTS Fixes: 59f0a0fd839e ("ipq806x: add Edgecore ECW5410 support") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 3b86760a19..ec73630ae5 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -109,6 +109,19 @@ define Device/compex_wpq864
endef
TARGET_DEVICES += compex_wpq864
+define Device/edgecore_ecw5410
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_VENDOR := Edgecore
+ DEVICE_MODEL := ECW5410
+ SOC := qcom-ipq8068
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DEVICE_DTS_CONFIG := config@v2.0-ap160
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct ipq-wifi-edgecore_ecw5410
+endef
+TARGET_DEVICES += edgecore_ecw5410
+
define Device/linksys_ea7500-v1
$(call Device/LegacyImage)
DEVICE_VENDOR := Linksys
@@ -126,18 +139,6 @@ define Device/linksys_ea7500-v1
endef
TARGET_DEVICES += linksys_ea7500-v1
-define Device/edgecore_ecw5410
- $(call Device/FitImage)
- $(call Device/UbiFit)
- DEVICE_TITLE := Edgecore ECW5410
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- DEVICE_DTS := qcom-ipq8068-ecw5410
- DEVICE_DTS_CONFIG := config@v2.0-ap160
- DEVICE_PACKAGES := ath10k-firmware-qca9984-ct ipq-wifi-edgecore_ecw5410
-endef
-TARGET_DEVICES += edgecore_ecw5410
-
define Device/linksys_ea8500
$(call Device/LegacyImage)
DEVICE_VENDOR := Linksys