aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/ase/target.mk
diff options
context:
space:
mode:
authorTino Reichardt <milky-lede@mcmilk.de>2017-02-26 21:26:08 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-06-03 21:14:07 +0200
commit9b321bc60de3ee6f41fa5bcb6593e07399782714 (patch)
treee1ec66c7f3b1fdc18ad8b0748ce128af846b4017 /target/linux/lantiq/ase/target.mk
parent1039e41deadd2d4f23b7b6ccdad28fbcc65cfdb4 (diff)
downloadupstream-9b321bc60de3ee6f41fa5bcb6593e07399782714.tar.gz
upstream-9b321bc60de3ee6f41fa5bcb6593e07399782714.tar.bz2
upstream-9b321bc60de3ee6f41fa5bcb6593e07399782714.zip
lantiq: add Amazon-SE subtarget
Re-Add support for the Amazon-SE subtarget on Lantiq. Signed-off-by: Tino Reichardt <milky-lede@mcmilk.de>
Diffstat (limited to 'target/linux/lantiq/ase/target.mk')
-rw-r--r--target/linux/lantiq/ase/target.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/lantiq/ase/target.mk b/target/linux/lantiq/ase/target.mk
new file mode 100644
index 0000000000..5f6c03b38e
--- /dev/null
+++ b/target/linux/lantiq/ase/target.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2016 LEDE Project
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+ARCH:=mips
+SUBTARGET:=ase
+BOARDNAME:=Amazon-SE
+FEATURES:=squashfs atm mips16 small_flash
+CPU_TYPE:=mips32
+
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug \
+ kmod-ltq-adsl-ase kmod-ltq-adsl-ase-mei \
+ kmod-ltq-adsl-ase-fw-b kmod-ltq-atm-ase \
+ ltq-adsl-app ppp-mod-pppoe
+
+define Target/Description
+ Lantiq Amazon-SE Boards
+endef