aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2017-10-03 12:46:09 +0200
committerMathias Kresin <dev@kresin.me>2017-10-06 08:28:41 +0200
commit254061ee97b9511f0d8981e3ea43406119e35ce4 (patch)
tree9b3755718b5269f2874362cde4ac0488f78e1e9b /target/linux/lantiq/image
parent90805b16b6d17dff861d456edf829858386ec559 (diff)
downloadupstream-254061ee97b9511f0d8981e3ea43406119e35ce4.tar.gz
upstream-254061ee97b9511f0d8981e3ea43406119e35ce4.tar.bz2
upstream-254061ee97b9511f0d8981e3ea43406119e35ce4.zip
build: add mktplinkfw2 hardcoded values to makefile
This patch adds all the board-specific values currently hardcoded in mktplinkfw2.c back to the respective device declarations in the makefiles. The rationale is to avoid modifying the source code every time a new board or board variant is added. Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/tp-link.mk15
1 files changed, 12 insertions, 3 deletions
diff --git a/target/linux/lantiq/image/tp-link.mk b/target/linux/lantiq/image/tp-link.mk
index 976184175a..5bbc18a852 100644
--- a/target/linux/lantiq/image/tp-link.mk
+++ b/target/linux/lantiq/image/tp-link.mk
@@ -1,6 +1,8 @@
-DEVICE_VARS += TPLINK_BOARD_ID
+DEVICE_VARS += TPLINK_FLASHLAYOUT TPLINK_HWID TPLINK_HWREV TPLINK_HWREVADD TPLINK_HVERSION
define Device/lantiqTpLink
+ TPLINK_HWREVADD := 0
+ TPLINK_HVERSION := 2
KERNEL := kernel-bin | append-dtb | lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | \
tplink-v2-header -s -V "ver. 1.0"
@@ -12,7 +14,9 @@ endef
define Device/TDW8970
$(Device/lantiqTpLink)
DEVICE_PROFILE := TDW8970
- TPLINK_BOARD_ID := TD-W8970v1
+ TPLINK_FLASHLAYOUT := 8Mltq
+ TPLINK_HWID := 0x89700001
+ TPLINK_HWREV := 1
IMAGE_SIZE := 7680k
DEVICE_TITLE := TP-LINK TD-W8970
DEVICE_PACKAGES:= kmod-ath9k wpad-mini kmod-usb-dwc2 kmod-usb-ledtrig-usbport
@@ -21,7 +25,9 @@ endef
define Device/TDW8980
$(Device/lantiqTpLink)
DEVICE_PROFILE := TDW8980
- TPLINK_BOARD_ID := TD-W8980v1
+ TPLINK_FLASHLAYOUT := 8Mltq
+ TPLINK_HWID := 0x89800001
+ TPLINK_HWREV := 14
IMAGE_SIZE := 7680k
DEVICE_TITLE := TP-LINK TD-W8980
DEVICE_PACKAGES:= kmod-ath9k kmod-owl-loader wpad-mini kmod-usb-dwc2 kmod-usb-ledtrig-usbport
@@ -31,6 +37,9 @@ define Device/VR200v
$(Device/lantiqTpLink)
DEVICE_PROFILE := VR200v
TPLINK_BOARD_ID := ArcherVR200V
+ TPLINK_FLASHLAYOUT := 16Mltq
+ TPLINK_HWID := 0x73b70801
+ TPLINK_HWREV := 0x2f
IMAGE_SIZE := 15808k
DEVICE_TITLE := TP-LINK Archer VR200v
DEVICE_PACKAGES:= kmod-usb-dwc2 kmod-usb-ledtrig-usbport