aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/modules.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-05 23:42:18 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-13 15:40:43 +0100
commit4caaa778f709a38c08a11d98dd7fb03fe257f8fe (patch)
tree9e7858ea623824c7c2d5c2782d655488c5b2c7da /target/linux/lantiq/modules.mk
parent4159054fbbf8a7176eaf3dd4467c5b0db70769d0 (diff)
downloadupstream-4caaa778f709a38c08a11d98dd7fb03fe257f8fe.tar.gz
upstream-4caaa778f709a38c08a11d98dd7fb03fe257f8fe.tar.bz2
upstream-4caaa778f709a38c08a11d98dd7fb03fe257f8fe.zip
kernel: make kmod-i2c-core selected by dependent modules
Currently kmod-i2c-* will not get into images unless kmod-i2c-core is added to DEVICE_PACKAGES as well. By changing the dependencies from "depends on" to "select", we do not have the issue anymore. Furthermore, we can remove most occurrences of the package from DEVICE_PACKAGES and similar variables, as it is now pulled by dependent modules such as: - kmod-hwmon-lm75 - kmod-i2c-gpio - kmod-i2c-gpio-custom - kmod-i2c-mux - kmod-i2c-ralink Signed-off-by: Sungbo Eo <mans0n@gorani.run> [do not touch ar71xx] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/lantiq/modules.mk')
-rw-r--r--target/linux/lantiq/modules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/lantiq/modules.mk b/target/linux/lantiq/modules.mk
index e7fbad3a29..8cd720093c 100644
--- a/target/linux/lantiq/modules.mk
+++ b/target/linux/lantiq/modules.mk
@@ -11,7 +11,7 @@ I2C_LANTIQ_MODULES:= \
define KernelPackage/i2c-lantiq
TITLE:=Lantiq I2C controller
$(call i2c_defaults,$(I2C_LANTIQ_MODULES),52)
- DEPENDS:=kmod-i2c-core @TARGET_lantiq_falcon
+ DEPENDS:=+kmod-i2c-core @TARGET_lantiq_falcon
endef
define KernelPackage/i2c-lantiq/description