aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.7/0303-vmmc.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-01-28 17:43:25 +0000
committerJohn Crispin <john@openwrt.org>2013-01-28 17:43:25 +0000
commit3534757bb9d3cbf9ed0a92932b1130a172104d28 (patch)
tree2ce5e44656f33b2841bf49ca1c451dd833579c00 /target/linux/lantiq/patches-3.7/0303-vmmc.patch
parent5eb43d4cf8451c965f92d56cf717918098e03321 (diff)
downloadupstream-3534757bb9d3cbf9ed0a92932b1130a172104d28.tar.gz
upstream-3534757bb9d3cbf9ed0a92932b1130a172104d28.tar.bz2
upstream-3534757bb9d3cbf9ed0a92932b1130a172104d28.zip
Add ath9k eeprom and pci fixup support
Add ath9k eeprom and pci fixup support (again) for linux 3.7. On linux 3.3, the fixup forced the regdomain to 0x67, causing low TX power. This patch only corrects checksum, the rest of the EEPROM isn't changed. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 35353
Diffstat (limited to 'target/linux/lantiq/patches-3.7/0303-vmmc.patch')
-rw-r--r--target/linux/lantiq/patches-3.7/0303-vmmc.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/lantiq/patches-3.7/0303-vmmc.patch b/target/linux/lantiq/patches-3.7/0303-vmmc.patch
index 4b5c280e82..c9af85bc89 100644
--- a/target/linux/lantiq/patches-3.7/0303-vmmc.patch
+++ b/target/linux/lantiq/patches-3.7/0303-vmmc.patch
@@ -1,19 +1,19 @@
-Index: linux-3.7.1/arch/mips/lantiq/xway/Makefile
+Index: linux-3.7.4/arch/mips/lantiq/xway/Makefile
===================================================================
---- linux-3.7.1.orig/arch/mips/lantiq/xway/Makefile 2013-01-09 09:30:35.000000000 +0100
-+++ linux-3.7.1/arch/mips/lantiq/xway/Makefile 2013-01-09 09:33:03.932167465 +0100
+--- linux-3.7.4.orig/arch/mips/lantiq/xway/Makefile 2013-01-28 18:10:31.000000000 +0100
++++ linux-3.7.4/arch/mips/lantiq/xway/Makefile 2013-01-28 18:14:12.224147075 +0100
@@ -1,6 +1,6 @@
obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
-obj-y += eth_mac.o
+obj-y += eth_mac.o vmmc.o
- obj-$(CONFIG_PCI) += ath_eep.o rt_eep.o
+ obj-$(CONFIG_PCI) += ath_eep.o rt_eep.o pci-ath-fixup.o
obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o
-Index: linux-3.7.1/arch/mips/lantiq/xway/vmmc.c
+Index: linux-3.7.4/arch/mips/lantiq/xway/vmmc.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7.1/arch/mips/lantiq/xway/vmmc.c 2013-01-09 09:31:49.264164272 +0100
++++ linux-3.7.4/arch/mips/lantiq/xway/vmmc.c 2013-01-28 18:13:53.128146621 +0100
@@ -0,0 +1,63 @@
+/*
+ * This program is free software; you can redistribute it and/or modify it