aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/armv8_64b/profiles/00-default.mk
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-06-29 11:19:07 +0800
committerJohn Crispin <john@phrozen.org>2017-10-07 23:13:22 +0200
commit806624add541bd828516a58aab20ae19ae9e431f (patch)
treee5bb450e4b18defde11492f2a3578f1ad04e8163 /target/linux/layerscape/armv8_64b/profiles/00-default.mk
parent4c89f2fcf8f6579257342cfca47293c0ac16fe86 (diff)
downloadupstream-806624add541bd828516a58aab20ae19ae9e431f.tar.gz
upstream-806624add541bd828516a58aab20ae19ae9e431f.tar.bz2
upstream-806624add541bd828516a58aab20ae19ae9e431f.zip
layerscape: rename subtargets and update makefile files
Rename subtargets 32b/64b with armv8_32b/armv8_64b which are more proper, and update makefile files. There also will be other subtargets added in the future, like armv7. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/armv8_64b/profiles/00-default.mk')
-rw-r--r--target/linux/layerscape/armv8_64b/profiles/00-default.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/layerscape/armv8_64b/profiles/00-default.mk b/target/linux/layerscape/armv8_64b/profiles/00-default.mk
new file mode 100644
index 0000000000..fc1231dc7a
--- /dev/null
+++ b/target/linux/layerscape/armv8_64b/profiles/00-default.mk
@@ -0,0 +1,18 @@
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+
+DEFAULT_PACKAGES+= \
+ rcw-layerscape-ls1043ardb uboot-layerscape-$(SUBTARGET)-ls1043ardb \
+ fman-layerscape-ls1043ardb \
+ rcw-layerscape-ls1046ardb uboot-layerscape-$(SUBTARGET)-ls1046ardb \
+ fman-layerscape-ls1046ardb \
+ rcw-layerscape-ls1012ardb uboot-layerscape-$(SUBTARGET)-ls1012ardb \
+ kmod-ppfe ppfe-ls1012ardb
+
+$(eval $(call Profile,Default))