aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image/Makefile
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-09-04 13:42:49 +0800
committerJohn Crispin <john@phrozen.org>2017-10-07 23:13:22 +0200
commite3f47958dd16137ea903ca3733435862d9f602ae (patch)
tree28493782bcde6a981e5372ab0c7c9026097334a2 /target/linux/layerscape/image/Makefile
parenta5ad3a2c808afb26db6dd54b0f974c9c902f0521 (diff)
downloadupstream-e3f47958dd16137ea903ca3733435862d9f602ae.tar.gz
upstream-e3f47958dd16137ea903ca3733435862d9f602ae.tar.bz2
upstream-e3f47958dd16137ea903ca3733435862d9f602ae.zip
layerscape: make uImage with zImage for 32-bit kernel
uImage should be made with zImage. This patch is to support making uImage with zImage. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/image/Makefile')
-rw-r--r--target/linux/layerscape/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 7f672d7db5..38bb06fe3d 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -33,15 +33,17 @@ endef
define Device/Default
PROFILES = Default
FILESYSTEMS := squashfs
- KERNEL := kernel-bin | gzip | uImage gzip
DEVICE_DTS :=
IMAGES = firmware.bin
ifeq ($(SUBTARGET),armv8_64b)
+ KERNEL := kernel-bin | gzip | uImage gzip
KERNEL_LOADADDR = 0x80080000
KERNEL_ENTRY_POINT = 0x80080000
endif
ifeq ($(SUBTARGET),armv8_32b)
+ KERNEL := kernel-bin | uImage none
+ KERNEL_NAME := zImage
KERNEL_LOADADDR = 0x80008000
KERNEL_ENTRY_POINT = 0x80008000
endif