aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image/armv7.mk
diff options
context:
space:
mode:
authorBiwen Li <biwen.li@nxp.com>2018-11-02 18:30:57 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-12-18 20:17:23 +0100
commit328530c6e7569d7be24e3524483f4453910003e9 (patch)
tree90ec1f99796fb88ebffb69380eb5adc0e60f34b8 /target/linux/layerscape/image/armv7.mk
parent0a827ebd2fa3c7dc210aff0a30d0dc1d536ed89c (diff)
downloadupstream-328530c6e7569d7be24e3524483f4453910003e9.tar.gz
upstream-328530c6e7569d7be24e3524483f4453910003e9.tar.bz2
upstream-328530c6e7569d7be24e3524483f4453910003e9.zip
layerscape: add LS1021AIOT board support
The LS1021A-IoT gateway reference design based on the QorIQ LS1021A processor is a purpose-built, small footprint hardware platform with a wide array of high-speed connectivity and low-speed serial interfaces to support secure delivery of IoT services for home, business or other commercial location. - Combines standards-based, open source software with a feature-rich IoT gateway design to establish a common, open framework for secured IoT service delivery and management. - Provides a wide assortment of high-speed and serial-based connectivity in a compact, highly secure design. - High efficiency through the use of the Arm-based QorIQ LS1021A embedded processor. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com> Signed-off-by: Biwen Li <biwen.li@nxp.com>
Diffstat (limited to 'target/linux/layerscape/image/armv7.mk')
-rw-r--r--target/linux/layerscape/image/armv7.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/layerscape/image/armv7.mk b/target/linux/layerscape/image/armv7.mk
index 7a582d79bf..04937a908d 100644
--- a/target/linux/layerscape/image/armv7.mk
+++ b/target/linux/layerscape/image/armv7.mk
@@ -45,3 +45,19 @@ define Device/ls1021atwr-sdboot
append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
endef
TARGET_DEVICES += ls1021atwr-sdboot
+
+define Device/ls1021aiot-sdboot
+ DEVICE_TITLE := LS1021AIOT (SD Card Boot)
+ DEVICE_DTS := ls1021a-iot
+ FILESYSTEMS := ext4
+ IMAGES := sdcard.img
+ IMAGE/sdcard.img := \
+ ls-clean | \
+ ls-append-sdhead $(1) | pad-to 4K | \
+ ls-append $(1)-uboot.bin | pad-to 1M | \
+ ls-append $(1)-uboot-env.bin | pad-to 15M | \
+ ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
+ append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
+endef
+TARGET_DEVICES += ls1021aiot-sdboot