aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-20 15:34:04 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-27 12:06:52 +0200
commit0f3c3a5fb2738b25c62eb0ff8ef7d0654c0b9300 (patch)
tree26b4069abaffe012b329d8a96b37ea9aac863c1d /target/linux/layerscape/image
parenta1eb2c463352d05161a756f806e8e8a039f4490c (diff)
downloadupstream-0f3c3a5fb2738b25c62eb0ff8ef7d0654c0b9300.tar.gz
upstream-0f3c3a5fb2738b25c62eb0ff8ef7d0654c0b9300.tar.bz2
upstream-0f3c3a5fb2738b25c62eb0ff8ef7d0654c0b9300.zip
layerscape: harmonize device strings
OpenWrt lately has harmonized device (definition) names to the pattern vendor_model to improve overall consistency, also with other values like the DTS compatible. This patch applies that scheme to the layerscape target. Since this (intentionally) creates a bigger overlap between DTS names, compatible, and device definition name, it also moves DEVICE_DTS and SUPPORTED_DEVICES definitions to the Device/Default blocks. Apart from that, it also modifies several packages to use consistent naming in order to keep the $(1) file references working. While at it, remove one layer of complexity for the setup in tfa-layerscape package. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/layerscape/image')
-rw-r--r--target/linux/layerscape/image/armv7.mk18
-rw-r--r--target/linux/layerscape/image/armv8_64b.mk90
2 files changed, 48 insertions, 60 deletions
diff --git a/target/linux/layerscape/image/armv7.mk b/target/linux/layerscape/image/armv7.mk
index e06c99c338..8a86997399 100644
--- a/target/linux/layerscape/image/armv7.mk
+++ b/target/linux/layerscape/image/armv7.mk
@@ -13,18 +13,19 @@ define Device/Default
KERNEL_NAME := zImage
KERNEL_LOADADDR := 0x80008000
KERNEL_ENTRY_POINT := 0x80008000
+ DEVICE_DTS = $(lastword $(subst _, ,$(1)))
+ SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
IMAGE_SIZE := 64m
IMAGE/sysupgrade.bin := append-kernel | pad-to 16M | \
append-rootfs | pad-rootfs | \
check-size $(LS_SYSUPGRADE_IMAGE_SIZE) | append-metadata
endef
-define Device/ls1021atwr
+define Device/fsl_ls1021a-twr
DEVICE_VENDOR := NXP
DEVICE_MODEL := TWR-LS1021A
DEVICE_VARIANT := Default
DEVICE_PACKAGES += layerscape-rcw
- DEVICE_DTS := ls1021a-twr
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-rcw.bin | pad-to 1M | \
@@ -33,11 +34,10 @@ define Device/ls1021atwr
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
append-rootfs | pad-rootfs | check-size
- SUPPORTED_DEVICES := fsl,ls1021a-twr
endef
-TARGET_DEVICES += ls1021atwr
+TARGET_DEVICES += fsl_ls1021a-twr
-define Device/ls1021atwr-sdboot
+define Device/fsl_ls1021a-twr-sdboot
DEVICE_VENDOR := NXP
DEVICE_MODEL := TWR-LS1021A
DEVICE_VARIANT := SD Card Boot
@@ -57,16 +57,16 @@ define Device/ls1021atwr-sdboot
ls-append-sdhead $(1) | pad-to 16M | \
append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
- SUPPORTED_DEVICES := fsl,ls1021a-twr-sdboot
endef
-TARGET_DEVICES += ls1021atwr-sdboot
+TARGET_DEVICES += fsl_ls1021a-twr-sdboot
-define Device/ls1021aiot-sdboot
+define Device/fsl_ls1021a-iot-sdboot
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS1021A-IoT
DEVICE_VARIANT := SD Card Boot
DEVICE_DTS := ls1021a-iot
FILESYSTEMS := ext4
+ SUPPORTED_DEVICES :=
IMAGES := sdcard.img
IMAGE/sdcard.img := \
ls-clean | \
@@ -77,4 +77,4 @@ define Device/ls1021aiot-sdboot
append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
endef
-TARGET_DEVICES += ls1021aiot-sdboot
+TARGET_DEVICES += fsl_ls1021a-iot-sdboot
diff --git a/target/linux/layerscape/image/armv8_64b.mk b/target/linux/layerscape/image/armv8_64b.mk
index b190e0c041..1bf956584c 100644
--- a/target/linux/layerscape/image/armv8_64b.mk
+++ b/target/linux/layerscape/image/armv8_64b.mk
@@ -12,20 +12,21 @@ define Device/Default
KERNEL := kernel-bin | gzip | uImage gzip
KERNEL_LOADADDR := 0x80080000
KERNEL_ENTRY_POINT := 0x80080000
+ DEVICE_DTS = freescale/$(subst _,-,$(1))
+ SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
IMAGE_SIZE := 64m
IMAGE/sysupgrade.bin := append-kernel | pad-to 16M | \
append-rootfs | pad-rootfs | \
check-size $(LS_SYSUPGRADE_IMAGE_SIZE) | append-metadata
endef
-define Device/ls1012afrdm
+define Device/fsl_ls1012a-frdm
DEVICE_VENDOR := NXP
DEVICE_MODEL := FRDM-LS1012A
DEVICE_PACKAGES += \
layerscape-ppfe \
- tfa-ls1012afrdm \
+ tfa-ls1012a-frdm \
kmod-ppfe
- DEVICE_DTS := freescale/fsl-ls1012a-frdm
BLOCKSIZE := 256KiB
IMAGE/firmware.bin := \
ls-clean | \
@@ -41,18 +42,16 @@ define Device/ls1012afrdm
check-size $(LS_SYSUPGRADE_IMAGE_SIZE) | append-metadata
KERNEL := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
KERNEL_INITRAMFS := kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb
- SUPPORTED_DEVICES := fsl,ls1012a-frdm
endef
-TARGET_DEVICES += ls1012afrdm
+TARGET_DEVICES += fsl_ls1012a-frdm
-define Device/ls1012ardb
+define Device/fsl_ls1012a-rdb
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS1012A-RDB
DEVICE_PACKAGES += \
layerscape-ppfe \
- tfa-ls1012ardb \
+ tfa-ls1012a-rdb \
kmod-ppfe
- DEVICE_DTS := freescale/fsl-ls1012a-rdb
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -62,16 +61,15 @@ define Device/ls1012ardb
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
append-rootfs | pad-rootfs | check-size
- SUPPORTED_DEVICES := fsl,ls1012a-rdb
endef
-TARGET_DEVICES += ls1012ardb
+TARGET_DEVICES += fsl_ls1012a-rdb
-define Device/ls1012afrwy
+define Device/fsl_ls1012a-frwy-sdboot
DEVICE_VENDOR := NXP
DEVICE_MODEL := FRWY-LS1012A
DEVICE_PACKAGES += \
layerscape-ppfe \
- tfa-ls1012afrwy \
+ tfa-ls1012a-frwy-sdboot \
kmod-ppfe
DEVICE_DTS := freescale/fsl-ls1012a-frwy
FILESYSTEMS := ext4
@@ -94,17 +92,16 @@ define Device/ls1012afrwy
ls-append-sdhead $(1) | pad-to 16M | \
append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
- SUPPORTED_DEVICES := fsl,ls1012a-frwy-sdboot
endef
-TARGET_DEVICES += ls1012afrwy
+TARGET_DEVICES += fsl_ls1012a-frwy-sdboot
-define Device/ls1043ardb
+define Device/fsl_ls1043a-rdb
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS1043A-RDB
DEVICE_VARIANT := Default
DEVICE_PACKAGES += \
layerscape-fman \
- tfa-ls1043ardb \
+ tfa-ls1043a-rdb \
fmc fmc-eth-config
DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
IMAGE/firmware.bin := \
@@ -116,17 +113,16 @@ define Device/ls1043ardb
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
append-rootfs | pad-rootfs | check-size
- SUPPORTED_DEVICES := fsl,ls1043a-rdb
endef
-TARGET_DEVICES += ls1043ardb
+TARGET_DEVICES += fsl_ls1043a-rdb
-define Device/ls1043ardb-sdboot
+define Device/fsl_ls1043a-rdb-sdboot
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS1043A-RDB
DEVICE_VARIANT := SD Card Boot
DEVICE_PACKAGES += \
layerscape-fman \
- tfa-ls1043ardb-sdboot \
+ tfa-ls1043a-rdb-sdboot \
fmc fmc-eth-config
DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
FILESYSTEMS := ext4
@@ -137,7 +133,7 @@ define Device/ls1043ardb-sdboot
ls-append $(1)-bl2.pbl | pad-to 1M | \
ls-append $(1)-fip.bin | pad-to 5M | \
ls-append $(1)-uboot-env.bin | pad-to 9M | \
- ls-append ls1043ardb-fman.bin | pad-to 15M | \
+ ls-append fsl_ls1043a-rdb-fman.bin | pad-to 15M | \
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
@@ -146,17 +142,16 @@ define Device/ls1043ardb-sdboot
ls-append-sdhead $(1) | pad-to 16M | \
append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
- SUPPORTED_DEVICES := fsl,ls1043a-rdb-sdboot
endef
-TARGET_DEVICES += ls1043ardb-sdboot
+TARGET_DEVICES += fsl_ls1043a-rdb-sdboot
-define Device/ls1046ardb
+define Device/fsl_ls1046a-rdb
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS1046A-RDB
DEVICE_VARIANT := Default
DEVICE_PACKAGES += \
layerscape-fman \
- tfa-ls1046ardb \
+ tfa-ls1046a-rdb \
fmc fmc-eth-config
DEVICE_DTS := freescale/fsl-ls1046a-rdb-sdk
IMAGE/firmware.bin := \
@@ -168,17 +163,16 @@ define Device/ls1046ardb
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
append-rootfs | pad-rootfs | check-size
- SUPPORTED_DEVICES := fsl,ls1046a-rdb
endef
-TARGET_DEVICES += ls1046ardb
+TARGET_DEVICES += fsl_ls1046a-rdb
-define Device/ls1046ardb-sdboot
+define Device/fsl_ls1046a-rdb-sdboot
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS1046A-RDB
DEVICE_VARIANT := SD Card Boot
DEVICE_PACKAGES += \
layerscape-fman \
- tfa-ls1046ardb-sdboot \
+ tfa-ls1046a-rdb-sdboot \
fmc fmc-eth-config
DEVICE_DTS := freescale/fsl-ls1046a-rdb-sdk
FILESYSTEMS := ext4
@@ -189,7 +183,7 @@ define Device/ls1046ardb-sdboot
ls-append $(1)-bl2.pbl | pad-to 1M | \
ls-append $(1)-fip.bin | pad-to 5M | \
ls-append $(1)-uboot-env.bin | pad-to 9M | \
- ls-append ls1046ardb-fman.bin | pad-to 15M | \
+ ls-append fsl_ls1046a-rdb-fman.bin | pad-to 15M | \
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
@@ -198,20 +192,18 @@ define Device/ls1046ardb-sdboot
ls-append-sdhead $(1) | pad-to 16M | \
append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
- SUPPORTED_DEVICES := fsl,ls1046a-rdb-sdboot
endef
-TARGET_DEVICES += ls1046ardb-sdboot
+TARGET_DEVICES += fsl_ls1046a-rdb-sdboot
-define Device/ls1088ardb
+define Device/fsl_ls1088a-rdb
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS1088A-RDB
DEVICE_VARIANT := Default
DEVICE_PACKAGES += \
layerscape-mc \
layerscape-dpl \
- tfa-ls1088ardb \
+ tfa-ls1088a-rdb \
restool
- DEVICE_DTS := freescale/fsl-ls1088a-rdb
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -223,18 +215,17 @@ define Device/ls1088ardb
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
append-rootfs | pad-rootfs | check-size
- SUPPORTED_DEVICES := fsl,ls1088a-rdb
endef
-TARGET_DEVICES += ls1088ardb
+TARGET_DEVICES += fsl_ls1088a-rdb
-define Device/ls1088ardb-sdboot
+define Device/fsl_ls1088a-rdb-sdboot
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS1088A-RDB
DEVICE_VARIANT := SD Card Boot
DEVICE_PACKAGES += \
layerscape-mc \
layerscape-dpl \
- tfa-ls1088ardb-sdboot \
+ tfa-ls1088a-rdb-sdboot \
restool
DEVICE_DTS := freescale/fsl-ls1088a-rdb
FILESYSTEMS := ext4
@@ -245,9 +236,9 @@ define Device/ls1088ardb-sdboot
ls-append $(1)-bl2.pbl | pad-to 1M | \
ls-append $(1)-fip.bin | pad-to 5M | \
ls-append $(1)-uboot-env.bin | pad-to 10M | \
- ls-append ls1088ardb-mc.itb | pad-to 13M | \
- ls-append ls1088ardb-dpl.dtb | pad-to 14M | \
- ls-append ls1088ardb-dpc.dtb | pad-to 15M | \
+ ls-append fsl_ls1088a-rdb-mc.itb | pad-to 13M | \
+ ls-append fsl_ls1088a-rdb-dpl.dtb | pad-to 14M | \
+ ls-append fsl_ls1088a-rdb-dpc.dtb | pad-to 15M | \
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
@@ -256,19 +247,17 @@ define Device/ls1088ardb-sdboot
ls-append-sdhead $(1) | pad-to 16M | \
append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
- SUPPORTED_DEVICES := fsl,ls1088a-rdb-sdboot
endef
-TARGET_DEVICES += ls1088ardb-sdboot
+TARGET_DEVICES += fsl_ls1088a-rdb-sdboot
-define Device/ls2088ardb
+define Device/fsl_ls2088a-rdb
DEVICE_VENDOR := NXP
DEVICE_MODEL := LS2088ARDB
DEVICE_PACKAGES += \
layerscape-mc \
layerscape-dpl \
- tfa-ls2088ardb \
+ tfa-ls2088a-rdb \
restool
- DEVICE_DTS := freescale/fsl-ls2088a-rdb
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -280,11 +269,10 @@ define Device/ls2088ardb
ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
append-rootfs | pad-rootfs | check-size
- SUPPORTED_DEVICES := fsl,ls2088a-rdb
endef
-TARGET_DEVICES += ls2088ardb
+TARGET_DEVICES += fsl_ls2088a-rdb
-define Device/traverse-ls1043
+define Device/traverse_ls1043
DEVICE_VENDOR := Traverse
DEVICE_MODEL := LS1043 Boards
KERNEL_NAME := Image
@@ -314,4 +302,4 @@ define Device/traverse-ls1043
MKUBIFS_OPTS := -m 2048 -e 124KiB -c 4096
SUPPORTED_DEVICES := traverse,ls1043s traverse,ls1043v
endef
-TARGET_DEVICES += traverse-ls1043
+TARGET_DEVICES += traverse_ls1043