aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-10-26 15:49:31 +0800
committerJohn Crispin <john@phrozen.org>2017-11-10 23:00:49 +0100
commit5b8639f02e2680cbf3a0a5ffe0a9959386e9230b (patch)
tree3b77511091358f4cc135675e1b4e9a7aa6dcf750 /target/linux/layerscape/image
parent82fbca8aaa6b35d96e555bc6c2edbda1fde21b11 (diff)
downloadupstream-5b8639f02e2680cbf3a0a5ffe0a9959386e9230b.tar.gz
upstream-5b8639f02e2680cbf3a0a5ffe0a9959386e9230b.tar.bz2
upstream-5b8639f02e2680cbf3a0a5ffe0a9959386e9230b.zip
layerscape: add ppa firmware package
This patch is to add PPA (The Primary Protected Application) package and also enable it for all layerscape devices. LSDK github provides ppa source code git tree, but it only could be compiled with 64-bit toolchain. For 32-bit devices, there was no method to use it. https://github.com/qoriq-open-source/ppa-generic This patch is to directly use a private ppa binary tree for both 32-bit and 64-bit devices. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/image')
-rw-r--r--target/linux/layerscape/image/Makefile33
1 files changed, 23 insertions, 10 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 85a6b822eb..d1449aa105 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -16,6 +16,10 @@ define Build/append-ls-uboot
dd if=$(STAGING_DIR_IMAGE)/$(1)-$(SUBTARGET)-uboot.bin >> $@
endef
+define Build/append-ls-ppa
+ dd if=$(STAGING_DIR_IMAGE)/$(1)-ppa.itb >> $@
+endef
+
define Build/append-ls-fman
dd if=$(STAGING_DIR_IMAGE)/$(1)-fman.bin >> $@
endef
@@ -67,10 +71,12 @@ endef
define Device/ls1043ardb
DEVICE_TITLE := ls1043ardb-$(SUBTARGET)
- DEVICE_PACKAGES += rcw-layerscape-ls1043ardb uboot-layerscape-$(SUBTARGET)-ls1043ardb fman-layerscape-ls1043ardb
+ DEVICE_PACKAGES += rcw-layerscape-ls1043ardb uboot-layerscape-$(SUBTARGET)-ls1043ardb \
+ fman-layerscape-ls1043ardb layerscape-ppa-ls1043ardb
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1043a-rdb-sdk
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 9M | \
+ append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-ppa $(1) | pad-to 9M | \
append-ls-fman $(1) | pad-to 15M | \
append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
@@ -80,10 +86,12 @@ TARGET_DEVICES += ls1043ardb
define Device/ls1046ardb
DEVICE_TITLE := ls1046ardb-$(SUBTARGET)
- DEVICE_PACKAGES += rcw-layerscape-ls1046ardb uboot-layerscape-$(SUBTARGET)-ls1046ardb fman-layerscape-ls1046ardb
+ DEVICE_PACKAGES += rcw-layerscape-ls1046ardb uboot-layerscape-$(SUBTARGET)-ls1046ardb \
+ fman-layerscape-ls1046ardb layerscape-ppa-ls1046ardb
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1046a-rdb-sdk
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 9M | \
+ append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-ppa $(1) | pad-to 9M | \
append-ls-fman $(1) | pad-to 15M | \
append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
@@ -94,10 +102,11 @@ TARGET_DEVICES += ls1046ardb
define Device/ls1012ardb
DEVICE_TITLE := ls1012ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls1012ardb uboot-layerscape-$(SUBTARGET)-ls1012ardb \
- kmod-ppfe layerscape-ppfe
+ kmod-ppfe layerscape-ppfe layerscape-ppa-ls1012ardb
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-rdb
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 10M | \
+ append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-ppa $(1) | pad-to 10M | \
append-ls-ppfe | pad-to 15M | \
append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
@@ -109,10 +118,12 @@ ifeq ($(SUBTARGET),armv8_64b)
define Device/ls1088ardb
DEVICE_TITLE := ls1088ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls1088ardb uboot-layerscape-$(SUBTARGET)-ls1088ardb \
- layerscape-mc-ls1088ardb layerscape-dpl-ls1088ardb restool
+ layerscape-mc-ls1088ardb layerscape-dpl-ls1088ardb restool \
+ layerscape-ppa-ls1088ardb
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1088a-rdb
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 10M | \
+ append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-ppa $(1) | pad-to 10M | \
append-ls-mc $(1) | pad-to 13M | \
append-ls-dpl $(1) | pad-to 14M | \
append-ls-dpc $(1) | pad-to 15M | \
@@ -125,10 +136,12 @@ TARGET_DEVICES += ls1088ardb
define Device/ls2088ardb
DEVICE_TITLE := ls2088ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls2088ardb uboot-layerscape-$(SUBTARGET)-ls2088ardb \
- layerscape-mc-ls2088ardb layerscape-dpl-ls2088ardb restool
+ layerscape-mc-ls2088ardb layerscape-dpl-ls2088ardb restool \
+ layerscape-ppa-ls2088ardb
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls2088a-rdb
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 10M | \
+ append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-ppa $(1) | pad-to 10M | \
append-ls-mc $(1) | pad-to 13M | \
append-ls-dpl $(1) | pad-to 14M | \
append-ls-dpc $(1) | pad-to 15M | \