aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2018-07-17 17:42:47 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-09-22 21:20:56 +0200
commitad1dbc0ca304686a7f826528e674620791f34584 (patch)
treec33516cb3780c225e9dfe2e5cb48392722ec49f8 /target/linux/layerscape/image
parentdcf57c766acc5224e05f62cf5fae2d965abace59 (diff)
downloadupstream-ad1dbc0ca304686a7f826528e674620791f34584.tar.gz
upstream-ad1dbc0ca304686a7f826528e674620791f34584.tar.bz2
upstream-ad1dbc0ca304686a7f826528e674620791f34584.zip
layerscape: add u-boot environment support for OpenWrt boot
This patch is to implement u-boot environment txt files to support OpenWrt boot for all layerscape devices. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/image')
-rw-r--r--target/linux/layerscape/image/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 8e85f76848..be091318ab 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -18,6 +18,10 @@ define Build/append-ls-uboot
dd if=$(STAGING_DIR_IMAGE)/$(1)-uboot.bin >> $@
endef
+define Build/append-ls-uboot-env
+ dd if=$(STAGING_DIR_IMAGE)/$(1)-uboot-env.bin >> $@
+endef
+
define Build/append-ls-ppa
dd if=$(STAGING_DIR_IMAGE)/$(1)-ppa.itb >> $@
endef
@@ -86,7 +90,8 @@ define Device/ls1043ardb
endif
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1043a-rdb-sdk
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-uboot $(1) | pad-to 3M | \
+ append-ls-uboot-env $(1) | pad-to 4M | \
append-ls-ppa $(1) | pad-to 9M | \
append-ls-fman $(1) | pad-to 15M | \
append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
@@ -109,7 +114,8 @@ define Device/ls1046ardb
BLOCKSIZE := 256KiB
PAGESIZE := 1
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-uboot $(1) | pad-to 3M | \
+ append-ls-uboot-env $(1) | pad-to 4M | \
append-ls-ppa $(1) | pad-to 9M | \
append-ls-fman $(1) | pad-to 15M | \
append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
@@ -132,7 +138,8 @@ define Device/ls1012ardb
BLOCKSIZE := 256KiB
PAGESIZE := 1
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-uboot $(1) | pad-to 3M | \
+ append-ls-uboot-env $(1) | pad-to 4M | \
append-ls-ppa $(1) | pad-to 10M | \
append-ls-ppfe | pad-to 15M | \
append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
@@ -155,7 +162,8 @@ define Device/ls1012afrdm
BLOCKSIZE := 256KiB
PAGESIZE := 1
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-uboot $(1) | pad-to 3M | \
+ append-ls-uboot-env $(1) | pad-to 4M | \
append-ls-ppa $(1) | pad-to 10M | \
append-ls-ppfe | pad-to 15M | \
append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
@@ -177,7 +185,8 @@ define Device/ls1088ardb
BLOCKSIZE := 256KiB
PAGESIZE := 1
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-uboot $(1) | pad-to 3M | \
+ append-ls-uboot-env $(1) | pad-to 4M | \
append-ls-ppa $(1) | pad-to 10M | \
append-ls-mc $(1) | pad-to 13M | \
append-ls-dpl $(1) | pad-to 14M | \
@@ -195,7 +204,8 @@ define Device/ls2088ardb
layerscape-ppa-ls2088ardb
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls2088a-rdb
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-uboot $(1) | pad-to 3M | \
+ append-ls-uboot-env $(1) | pad-to 4M | \
append-ls-ppa $(1) | pad-to 10M | \
append-ls-mc $(1) | pad-to 13M | \
append-ls-dpl $(1) | pad-to 14M | \