aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2019-04-18 18:48:00 +0800
committerPetr Štetiar <ynezz@true.cz>2019-06-06 15:40:08 +0200
commitb4b53cd39b128dd583871fd639957c381d9eae57 (patch)
treed575a664e6c9beacf3c06abdc4072c33580c9012 /target/linux/layerscape/image
parent9ad7c53383dd479a265762c4ffb73b8a2f126129 (diff)
downloadupstream-b4b53cd39b128dd583871fd639957c381d9eae57.tar.gz
upstream-b4b53cd39b128dd583871fd639957c381d9eae57.tar.bz2
upstream-b4b53cd39b128dd583871fd639957c381d9eae57.zip
layerscape: drop armv8_32b support
NXP LSDK has decided to drop armv8_32b support considering few users are using it. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/image')
-rw-r--r--target/linux/layerscape/image/Makefile4
-rw-r--r--target/linux/layerscape/image/armv8_32b.mk116
2 files changed, 0 insertions, 120 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 884daa5c21..bc65748853 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -47,10 +47,6 @@ ifeq ($(SUBTARGET),armv8_64b)
include armv8_64b.mk
endif
-ifeq ($(SUBTARGET),armv8_32b)
-include armv8_32b.mk
-endif
-
ifeq ($(SUBTARGET),armv7)
include armv7.mk
endif
diff --git a/target/linux/layerscape/image/armv8_32b.mk b/target/linux/layerscape/image/armv8_32b.mk
deleted file mode 100644
index 8410c3b4dd..0000000000
--- a/target/linux/layerscape/image/armv8_32b.mk
+++ /dev/null
@@ -1,116 +0,0 @@
-#
-# Copyright 2018 NXP
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Device/Default
- PROFILES := Default
- IMAGES := firmware.bin
- FILESYSTEMS := ubifs
- MKUBIFS_OPTS := -m 1 -e 262016 -c 128
- KERNEL := kernel-bin | uImage none
- KERNEL_NAME := zImage
- KERNEL_LOADADDR := 0x80008000
- KERNEL_ENTRY_POINT := 0x80008000
-endef
-
-define Device/ls1012ardb
- DEVICE_TITLE := LS1012ARDB
- DEVICE_PACKAGES += \
- layerscape-rcw-ls1012ardb \
- layerscape-ppfe \
- layerscape-ppa-ls1012ardb \
- u-boot-ls1012ardb-image \
- kmod-ppfe
- DEVICE_DTS := ../../../arm64/boot/dts/freescale/fsl-ls1012a-rdb
- UBINIZE_OPTS := -E 5
- BLOCKSIZE := 256KiB
- PAGESIZE := 1
- IMAGE/firmware.bin := \
- ls-clean | \
- ls-append $(1)-rcw.bin | pad-to 1M | \
- ls-append $(1)-uboot.bin | pad-to 3M | \
- ls-append $(1)-uboot-env.bin | pad-to 4M | \
- ls-append $(1)-ppa.itb | pad-to 10M | \
- ls-append pfe.itb | pad-to 15M | \
- ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
- append-kernel | pad-to 32M | \
- append-ubi | check-size 67108865
-endef
-TARGET_DEVICES += ls1012ardb
-
-define Device/ls1012afrwy
- DEVICE_TITLE := LS1012AFRWY
- DEVICE_PACKAGES += \
- layerscape-rcw-ls1012afrwy \
- layerscape-ppfe \
- layerscape-ppa-ls1012afrwy \
- u-boot-ls1012afrwy-image \
- kmod-ppfe
- DEVICE_DTS := ../../../arm64/boot/dts/freescale/fsl-ls1012a-frwy
- FILESYSTEMS := ext4
- IMAGES := firmware.bin sdcard.img
- IMAGE/firmware.bin := \
- ls-clean | \
- ls-append $(1)-rcw.bin | pad-to 128K | \
- ls-append pfe.itb | pad-to 384K | \
- ls-append $(1)-ppa.itb | pad-to 1024K | \
- ls-append $(1)-uboot.bin | pad-to 1856K | \
- ls-append $(1)-uboot-env.bin | pad-to 2048K | \
- check-size 2097153
- IMAGE/sdcard.img := \
- ls-clean | \
- ls-append-sdhead $(1) | pad-to 15M | \
- ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
- append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
- append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
-endef
-TARGET_DEVICES += ls1012afrwy
-
-define Device/ls1043ardb
- DEVICE_TITLE := LS1043ARDB
- DEVICE_PACKAGES += \
- layerscape-rcw-ls1043ardb \
- layerscape-fman-ls1043ardb \
- layerscape-ppa-ls1043ardb \
- u-boot-ls1043ardb-image
- DEVICE_DTS := ../../../arm64/boot/dts/freescale/fsl-ls1043a-rdb-sdk
- FILESYSTEMS := squashfs
- IMAGE/firmware.bin := \
- ls-clean | \
- ls-append $(1)-rcw.bin | pad-to 1M | \
- ls-append $(1)-uboot.bin | pad-to 3M | \
- ls-append $(1)-uboot-env.bin | pad-to 4M | \
- ls-append $(1)-ppa.itb | pad-to 9M | \
- ls-append $(1)-fman.bin | pad-to 15M | \
- ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
- append-kernel | pad-to 32M | \
- append-rootfs | pad-rootfs | check-size 67108865
-endef
-TARGET_DEVICES += ls1043ardb
-
-define Device/ls1046ardb
- DEVICE_TITLE := LS1046ARDB
- DEVICE_PACKAGES += \
- layerscape-rcw-ls1046ardb \
- layerscape-fman-ls1046ardb \
- layerscape-ppa-ls1046ardb \
- u-boot-ls1046ardb-image
- DEVICE_DTS := ../../../arm64/boot/dts/freescale/fsl-ls1046a-rdb-sdk
- UBINIZE_OPTS := -E 5
- BLOCKSIZE := 256KiB
- PAGESIZE := 1
- IMAGE/firmware.bin := \
- ls-clean | \
- ls-append $(1)-rcw.bin | pad-to 1M | \
- ls-append $(1)-uboot.bin | pad-to 3M | \
- ls-append $(1)-uboot-env.bin | pad-to 4M | \
- ls-append $(1)-ppa.itb | pad-to 9M | \
- ls-append $(1)-fman.bin | pad-to 15M | \
- ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
- append-kernel | pad-to 32M | \
- append-ubi | check-size 67108865
-endef
-TARGET_DEVICES += ls1046ardb