aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/modules.mk
diff options
context:
space:
mode:
authorYutang Jiang <yutang.jiang@nxp.com>2016-10-29 00:18:23 +0800
committerJohn Crispin <john@phrozen.org>2016-10-31 17:00:10 +0100
commit15a14cf1665ef3d8b5c77cce69b52d131340e3b3 (patch)
treebd544b24bd3e7fc7efc61f80e1755274971c5582 /target/linux/layerscape/modules.mk
parentc6c731fe311f7da42777ffd31804a4f6aa3f8e19 (diff)
downloadupstream-15a14cf1665ef3d8b5c77cce69b52d131340e3b3.tar.gz
upstream-15a14cf1665ef3d8b5c77cce69b52d131340e3b3.tar.bz2
upstream-15a14cf1665ef3d8b5c77cce69b52d131340e3b3.zip
layerscape: add 64b/32b target for ls1012ardb device
The QorIQ LS1012A processor, optimized for battery-backed or USB-powered, integrates a single ARM Cortex-A53 core with a hardware packet forwarding engine and high-speed interfaces to deliver line-rate networking performance. QorIQ LS1012A Reference Design System (LS1012ARDB) is a high-performance development platform, with a complete debugging environment. The LS1012ARDB board supports the QorIQ LS1012A processor and is optimized to support the high-bandwidth DDR3L memory and a full complement of high-speed SerDes ports. LEDE/OPENWRT will auto strip executable program file while make. So we need select CONFIG_NO_STRIP=y while make menuconfig to avoid the ppfe network fiemware be destroyed, then run make to build ls1012ardb firmware. The fsl-quadspi flash with jffs2 fs is unstable and arise some failed message. This issue have noticed the IP owner for investigate, hope he can solve it earlier. So the ls1012ardb now also provide a xx-firmware.ext4.bin as default firmware, and the uboot bootcmd will run wrtboot_ext4rfs for "rootfstype=ext4" bootargs. Signed-off-by: Yutang Jiang <yutang.jiang@nxp.com>
Diffstat (limited to 'target/linux/layerscape/modules.mk')
-rw-r--r--target/linux/layerscape/modules.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/layerscape/modules.mk b/target/linux/layerscape/modules.mk
new file mode 100644
index 0000000000..0b34f96b33
--- /dev/null
+++ b/target/linux/layerscape/modules.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) Jiang Yutang <jiangyutang1978@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/ppfe
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Freescale PPFE Driver support
+ KCONFIG:=CONFIG_FSL_PPFE
+ FILES:=$(LINUX_DIR)/drivers/staging/fsl_ppfe/pfe.ko
+ AUTOLOAD:=$(call AutoLoad,35,ppfe)
+endef
+
+define KernelPackage/ppfe/description
+ Kernel modules for Freescale PPFE Driver support.
+endef
+
+$(eval $(call KernelPackage,ppfe))