aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-03-21 01:16:48 +0000
committerDaniel Golle <daniel@makrotopia.org>2022-03-21 13:11:56 +0000
commit786bf7fdaca4c75e7eba6e9aa3a8b5775fd21186 (patch)
tree926fecb2b1f6ce1e42ba7ef4c7aab8e68dfd214c /target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch
parent9470160c350d15f765c33d6c1db15d6c4709a64c (diff)
downloadupstream-786bf7fdaca4c75e7eba6e9aa3a8b5775fd21186.tar.gz
upstream-786bf7fdaca4c75e7eba6e9aa3a8b5775fd21186.tar.bz2
upstream-786bf7fdaca4c75e7eba6e9aa3a8b5775fd21186.zip
kernel: delete Linux 5.4 config and patches
As the upcoming release will be based on Linux 5.10 only, remove all kernel configuration as well as patches for Linux 5.4. There were no targets still actively using Linux 5.4. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit 3a14580411adfb75f9a44eded9f41245b9e44606)
Diffstat (limited to 'target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch')
-rw-r--r--target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch61
1 files changed, 0 insertions, 61 deletions
diff --git a/target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch b/target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch
deleted file mode 100644
index 5d8c35d04f..0000000000
--- a/target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 69673b5ab6f814cf679285f0c45baa318ab9e0d7 Mon Sep 17 00:00:00 2001
-From: Zhao Qiang <qiang.zhao@nxp.com>
-Date: Thu, 27 Apr 2017 10:22:12 +0800
-Subject: [PATCH] config/qe: add irq-qeic support.
-
-Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
----
- MAINTAINERS | 6 ++++++
- drivers/irqchip/Makefile | 1 +
- drivers/net/ethernet/freescale/Kconfig | 11 ++++++-----
- 3 files changed, 13 insertions(+), 5 deletions(-)
-
---- a/MAINTAINERS
-+++ b/MAINTAINERS
-@@ -6598,6 +6598,12 @@ F: drivers/soc/fsl/qe/
- F: include/soc/fsl/*qe*.h
- F: include/soc/fsl/*ucc*.h
-
-+FREESCALE QEIC DRIVERS
-+M: Qiang Zhao <qiang.zhao@nxp.com>
-+L: linux-kernel@vger.kernel.org
-+S: Maintained
-+F: drivers/irqchip/irq-qeic.c
-+
- FREESCALE QUICC ENGINE UCC ETHERNET DRIVER
- M: Li Yang <leoyang.li@nxp.com>
- L: netdev@vger.kernel.org
---- a/drivers/irqchip/Makefile
-+++ b/drivers/irqchip/Makefile
-@@ -103,3 +103,4 @@ obj-$(CONFIG_MADERA_IRQ) += irq-madera.
- obj-$(CONFIG_LS1X_IRQ) += irq-ls1x.o
- obj-$(CONFIG_TI_SCI_INTR_IRQCHIP) += irq-ti-sci-intr.o
- obj-$(CONFIG_TI_SCI_INTA_IRQCHIP) += irq-ti-sci-inta.o
-+obj-$(CONFIG_QUICC_ENGINE) += irq-qeic.o
---- a/drivers/net/ethernet/freescale/Kconfig
-+++ b/drivers/net/ethernet/freescale/Kconfig
-@@ -6,10 +6,11 @@
- config NET_VENDOR_FREESCALE
- bool "Freescale devices"
- default y
-- depends on FSL_SOC || QUICC_ENGINE || CPM1 || CPM2 || PPC_MPC512x || \
-- M523x || M527x || M5272 || M528x || M520x || M532x || \
-- ARCH_MXC || ARCH_MXS || (PPC_MPC52xx && PPC_BESTCOMM) || \
-- ARCH_LAYERSCAPE || COMPILE_TEST
-+ depends on FSL_SOC || (QUICC_ENGINE && PPC32) || CPM1 || CPM2 || \
-+ PPC_MPC512x || M523x || M527x || M5272 || M528x || M520x || \
-+ M532x || ARCH_MXC || ARCH_MXS || \
-+ (PPC_MPC52xx && PPC_BESTCOMM) || ARCH_LAYERSCAPE || \
-+ COMPILE_TEST
- ---help---
- If you have a network (Ethernet) card belonging to this class, say Y.
-
-@@ -74,7 +75,7 @@ config FSL_XGMAC_MDIO
-
- config UCC_GETH
- tristate "Freescale QE Gigabit Ethernet"
-- depends on QUICC_ENGINE
-+ depends on QUICC_ENGINE && FSL_SOC && PPC32
- select FSL_PQ_MDIO
- select PHYLIB
- select FIXED_PHY