aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2020-04-10 10:47:05 +0800
committerPetr Štetiar <ynezz@true.cz>2020-05-07 12:53:06 +0200
commitcddd4591404fb4c53dc0b3c0b15b942cdbed4356 (patch)
tree392c1179de46b0f804e3789edca19069b64e6b44 /target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch
parentd1d2c0b5579ea4f69a42246c9318539d61ba1999 (diff)
downloadupstream-cddd4591404fb4c53dc0b3c0b15b942cdbed4356.tar.gz
upstream-cddd4591404fb4c53dc0b3c0b15b942cdbed4356.tar.bz2
upstream-cddd4591404fb4c53dc0b3c0b15b942cdbed4356.zip
layerscape: add patches-5.4
Add patches for linux-5.4. The patches are from NXP LSDK-20.04 release which was tagged LSDK-20.04-V5.4. https://source.codeaurora.org/external/qoriq/qoriq-components/linux/ For boards LS1021A-IOT, and Traverse-LS1043 which are not involved in LSDK, port the dts patches from 4.14. The patches are sorted into the following categories: 301-arch-xxxx 302-dts-xxxx 303-core-xxxx 701-net-xxxx 801-audio-xxxx 802-can-xxxx 803-clock-xxxx 804-crypto-xxxx 805-display-xxxx 806-dma-xxxx 807-gpio-xxxx 808-i2c-xxxx 809-jailhouse-xxxx 810-keys-xxxx 811-kvm-xxxx 812-pcie-xxxx 813-pm-xxxx 814-qe-xxxx 815-sata-xxxx 816-sdhc-xxxx 817-spi-xxxx 818-thermal-xxxx 819-uart-xxxx 820-usb-xxxx 821-vfio-xxxx Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch')
-rw-r--r--target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch b/target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch
new file mode 100644
index 0000000000..7aaf8c7162
--- /dev/null
+++ b/target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch
@@ -0,0 +1,61 @@
+From 69673b5ab6f814cf679285f0c45baa318ab9e0d7 Mon Sep 17 00:00:00 2001
+From: Zhao Qiang <qiang.zhao@nxp.com>
+Date: Thu, 27 Apr 2017 10:22:12 +0800
+Subject: [PATCH] config/qe: add irq-qeic support.
+
+Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
+---
+ MAINTAINERS | 6 ++++++
+ drivers/irqchip/Makefile | 1 +
+ drivers/net/ethernet/freescale/Kconfig | 11 ++++++-----
+ 3 files changed, 13 insertions(+), 5 deletions(-)
+
+--- a/MAINTAINERS
++++ b/MAINTAINERS
+@@ -6596,6 +6596,12 @@ F: drivers/soc/fsl/qe/
+ F: include/soc/fsl/*qe*.h
+ F: include/soc/fsl/*ucc*.h
+
++FREESCALE QEIC DRIVERS
++M: Qiang Zhao <qiang.zhao@nxp.com>
++L: linux-kernel@vger.kernel.org
++S: Maintained
++F: drivers/irqchip/irq-qeic.c
++
+ FREESCALE QUICC ENGINE UCC ETHERNET DRIVER
+ M: Li Yang <leoyang.li@nxp.com>
+ L: netdev@vger.kernel.org
+--- a/drivers/irqchip/Makefile
++++ b/drivers/irqchip/Makefile
+@@ -103,3 +103,4 @@ obj-$(CONFIG_MADERA_IRQ) += irq-madera.
+ obj-$(CONFIG_LS1X_IRQ) += irq-ls1x.o
+ obj-$(CONFIG_TI_SCI_INTR_IRQCHIP) += irq-ti-sci-intr.o
+ obj-$(CONFIG_TI_SCI_INTA_IRQCHIP) += irq-ti-sci-inta.o
++obj-$(CONFIG_QUICC_ENGINE) += irq-qeic.o
+--- a/drivers/net/ethernet/freescale/Kconfig
++++ b/drivers/net/ethernet/freescale/Kconfig
+@@ -6,10 +6,11 @@
+ config NET_VENDOR_FREESCALE
+ bool "Freescale devices"
+ default y
+- depends on FSL_SOC || QUICC_ENGINE || CPM1 || CPM2 || PPC_MPC512x || \
+- M523x || M527x || M5272 || M528x || M520x || M532x || \
+- ARCH_MXC || ARCH_MXS || (PPC_MPC52xx && PPC_BESTCOMM) || \
+- ARCH_LAYERSCAPE || COMPILE_TEST
++ depends on FSL_SOC || (QUICC_ENGINE && PPC32) || CPM1 || CPM2 || \
++ PPC_MPC512x || M523x || M527x || M5272 || M528x || M520x || \
++ M532x || ARCH_MXC || ARCH_MXS || \
++ (PPC_MPC52xx && PPC_BESTCOMM) || ARCH_LAYERSCAPE || \
++ COMPILE_TEST
+ ---help---
+ If you have a network (Ethernet) card belonging to this class, say Y.
+
+@@ -74,7 +75,7 @@ config FSL_XGMAC_MDIO
+
+ config UCC_GETH
+ tristate "Freescale QE Gigabit Ethernet"
+- depends on QUICC_ENGINE
++ depends on QUICC_ENGINE && FSL_SOC && PPC32
+ select FSL_PQ_MDIO
+ select PHYLIB
+ ---help---