aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-05-04 16:28:11 +0200
committerJohn Crispin <john@phrozen.org>2020-05-04 16:28:46 +0200
commit220f43e0f2a0870305d40add4c3314edf150f9be (patch)
tree810265a0f2821357c6d5c94373f53fa689100067 /target/linux/mediatek/image/Makefile
parentabb0452cd8ec4e7d131d9728e5dd3b613dd10bbb (diff)
downloadupstream-220f43e0f2a0870305d40add4c3314edf150f9be.tar.gz
upstream-220f43e0f2a0870305d40add4c3314edf150f9be.tar.bz2
upstream-220f43e0f2a0870305d40add4c3314edf150f9be.zip
mediatek: fix image building
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/mediatek/image/Makefile')
-rw-r--r--target/linux/mediatek/image/Makefile26
1 files changed, 2 insertions, 24 deletions
diff --git a/target/linux/mediatek/image/Makefile b/target/linux/mediatek/image/Makefile
index ddf4e435c7..385277fd3d 100644
--- a/target/linux/mediatek/image/Makefile
+++ b/target/linux/mediatek/image/Makefile
@@ -8,18 +8,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-# for arm
-KERNEL_LOADADDR := 0x80008000
-
-# for arm64
-ifeq ($(SUBTARGET),mt7622)
-KERNEL_LOADADDR = 0x41080000
-endif
-
-ifeq ($(SUBTARGET),mt7629)
-KERNEL_LOADADDR = 0x40008000
-endif
-
define Build/sysupgrade-emmc
rm -f $@.recovery
mkfs.fat -C $@.recovery 3070
@@ -37,7 +25,7 @@ define Device/Default
FILESYSTEMS := squashfs
DEVICE_DTS_DIR := $(DTS_DIR)
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 128k | append-rootfs | pad-rootfs | append-metadata
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
ifeq ($(SUBTARGET),mt7623)
KERNEL_NAME := zImage
@@ -50,17 +38,7 @@ else
endif
endef
-ifeq ($(SUBTARGET),mt7622)
-include mt7622.mk
-endif
-
-ifeq ($(SUBTARGET),mt7623)
-include mt7623.mk
-endif
-
-ifeq ($(SUBTARGET),mt7629)
-include mt7629.mk
-endif
+include $(SUBTARGET).mk
define Image/Build
$(call Image/Build/$(1),$(1))