aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/generic/profiles/00-default.mk
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2017-10-20 12:36:25 -0500
committerMathias Kresin <dev@kresin.me>2017-10-25 09:21:54 +0200
commitec269290db46d491ae61adb64b19b3f171b8e2a3 (patch)
tree91602b2a24759dd57794878f1afb0f7769dbda92 /target/linux/mpc85xx/generic/profiles/00-default.mk
parentdcf62cb24efb2fd69eca921085c3f4306e76e8a2 (diff)
downloadupstream-ec269290db46d491ae61adb64b19b3f171b8e2a3.tar.gz
upstream-ec269290db46d491ae61adb64b19b3f171b8e2a3.tar.bz2
upstream-ec269290db46d491ae61adb64b19b3f171b8e2a3.zip
mpc85xx: use new build code style
The following moves the mpc85xx target (generic & P1020) to the new build code style. Compile & Flash tested on an Aerohive HiveAP-330. Signed-off-by: Chris Blake <chrisrblake93@gmail.com> Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/mpc85xx/generic/profiles/00-default.mk')
-rw-r--r--target/linux/mpc85xx/generic/profiles/00-default.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/generic/profiles/00-default.mk b/target/linux/mpc85xx/generic/profiles/00-default.mk
new file mode 100644
index 0000000000..67507ace8a
--- /dev/null
+++ b/target/linux/mpc85xx/generic/profiles/00-default.mk
@@ -0,0 +1,15 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most MPC85xx boards.
+endef
+
+$(eval $(call Profile,Default))