aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/p1010
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-05-18 21:10:40 +0200
committerDavid Bauer <mail@david-bauer.net>2020-05-18 21:11:22 +0200
commit564f87ef5bea16d5d1d8a9a80e8de77429159f26 (patch)
treedadca7e72b962ed3a7f091364942d2af8cecc855 /target/linux/mpc85xx/p1010
parent367a30389d298948a3c4867dd0261bb942371147 (diff)
downloadupstream-564f87ef5bea16d5d1d8a9a80e8de77429159f26.tar.gz
upstream-564f87ef5bea16d5d1d8a9a80e8de77429159f26.tar.bz2
upstream-564f87ef5bea16d5d1d8a9a80e8de77429159f26.zip
mpc85xx: rename generic subtarget to p1010
The mpc85xx-generic subtarget supports the QorIQ SoCs of the p1010 family. Rename the subtarget to reflect this affiliation as it's the case with the other mpc85xx subtargets. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/mpc85xx/p1010')
-rw-r--r--target/linux/mpc85xx/p1010/config-default18
-rw-r--r--target/linux/mpc85xx/p1010/profiles/00-default.mk15
-rw-r--r--target/linux/mpc85xx/p1010/target.mk8
3 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/p1010/config-default b/target/linux/mpc85xx/p1010/config-default
new file mode 100644
index 0000000000..e25d51aeb1
--- /dev/null
+++ b/target/linux/mpc85xx/p1010/config-default
@@ -0,0 +1,18 @@
+# CONFIG_FSL_CORENET_CF is not set
+CONFIG_MTD_NAND_FSL_IFC=y
+CONFIG_MTD_SPLIT_FIRMWARE=y
+CONFIG_MTD_SPLIT_TPLINK_FW=y
+CONFIG_MTD_UBI=y
+CONFIG_MTD_UBI_BEB_LIMIT=20
+CONFIG_MTD_UBI_BLOCK=y
+# CONFIG_MTD_UBI_FASTMAP is not set
+# CONFIG_MTD_UBI_GLUEBI is not set
+CONFIG_MTD_UBI_WL_THRESHOLD=4096
+CONFIG_REALTEK_PHY=y
+CONFIG_RED_15W_REV1=y
+CONFIG_TL_WDR4900_V1=y
+CONFIG_UBIFS_FS=y
+CONFIG_UBIFS_FS_ADVANCED_COMPR=y
+CONFIG_UBIFS_FS_LZO=y
+CONFIG_UBIFS_FS_ZLIB=y
+CONFIG_UBIFS_FS_ZSTD=y
diff --git a/target/linux/mpc85xx/p1010/profiles/00-default.mk b/target/linux/mpc85xx/p1010/profiles/00-default.mk
new file mode 100644
index 0000000000..5356aaa939
--- /dev/null
+++ b/target/linux/mpc85xx/p1010/profiles/00-default.mk
@@ -0,0 +1,15 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most P1010 boards.
+endef
+
+$(eval $(call Profile,Default))
diff --git a/target/linux/mpc85xx/p1010/target.mk b/target/linux/mpc85xx/p1010/target.mk
new file mode 100644
index 0000000000..12ed78ace1
--- /dev/null
+++ b/target/linux/mpc85xx/p1010/target.mk
@@ -0,0 +1,8 @@
+BOARDNAME:=P1010
+FEATURES+=nand
+KERNELNAME:=simpleImage.tl-wdr4900-v1
+
+define Target/Description
+ Build firmware images for P1010 based boards.
+endef
+